Video: Have I bricked my PixHawk? Solid Red LED

[ul]RCTimer F800 (S800 clone)
3DR PixHawk (2nd owner)
6s Lipo(s)
Dshot 90A 30V power module
HKPilot Telem Radios[/ul]

I was outside attempting my maiden flight, troubleshooting some pre-arm issues. The first was a compass inconsistency, I re-calibrated and that was fine. Then my safety switch would not enable (it worked earlier during tests), preventing me from arming the flight controller. I used the telemetry radios, to change BRD_SAFETYENABLE parameter to 0, hoping it would allow me to bypass the need to enable the switch, and arm. I rebooted the flight controller and thats when this started happening.

Video Link <<<

Here is what I have attempted:
[ul]Powered by USB only
Powered by battery only
Tried a different powers module
Tried a different GPS module
Disconnected everything from the PixHawk
Formatted SD card
Tried a different SD card
Powered PixHawk while holding down safety switch (for both SD cards)
Tried a different safety switch
Flashed firmware to AudroPlan, then back to latest AudroCopter
Pressed both physical reset buttons
Held reset buttons while booting PixHawk[/ul]

Mission Planner allows me to flash firmware, but it does not connect to MavLink.
I’m on a MacBook Pro, running Windows 7 via BootCamp.
According to the Ardupilot common-Sounds page, the tone sounds like New IO board firmware found (restart with safety button pushed to upload). However, I could be wrong. I’m not sure if by me disabling BRD_SAFETYENABLE, it’s preventing the safty switch from working during boot up.

Any help or suggestions, is greatly appreciated.

I checked then BOOT.LOG file and it says “No PX4IO board found”.

Any help with this is greatly appreciated.