Servers by jDrones

Using BMP280 with Pixhawk running arduplane

(Niels Daemen) #1

here it says that support will be released in copter version 3.7
I guess it is already supported by arduplane 3.9?

if so, I wonder why I can’t get it to work

  • I connected this breakout board to the i2c bus

  • set GND_PROBE_EXT to 2

  • saved parameters

  • rebooted the pixhawk

  • press_abs2 = 0

  • press_temp2 = 0

Any suggestions?

(basti) #2

if you have the GND_PROBE_EXT parameter in your plane firmware, you‘re likely using master as this hasn‘t been added to plane 3.9 release versions yet.
additionally you‘ll have to specify the I2C bus to probe on, using the GND_EXT_BUS parameter which defaults to -1 (= disabled). iirc on pixhawk type hardware setting it to 1 will enable probing on the external I2C bus.

edit: depending on what actual firmware you‘re using, GND_EXT_BUS set to -1 enables probing on all external buses and does not need further specification. so double check your wiring too to rule out it‘d a connection issue.