use bendyruler with geofence

Recently, with the use of the avoidance function, the bendyruler worked successfully.
However, there are repeated attempts to avoid geofence in mission flights.
I don’t know why geofence is perceived as an obstacle when I want to avoid only the obstacles that actually exist.
Is there a solution?

Don’t put geofences where you want to fly…

1 Like

I know that AVOID_ENABLE bitmask controls which kind of object to avoid on manual modes, but I am not sure if there is a way to make it avoid only data from proximity sensors with OA_TYPE enabled… maybe you will have to give up of including exclusion fences in your plan…

And update to ArduCopter 4.3.2-rc1

1 Like