Updated windows installer to resolve "__builtin_bswap16" compile error

Since late last week there have been compile issues for those compiling for the Pixhawk family of boards using ardupilot/master. The error was “error: ‘__builtin_bswap16’ was not declared in this scope” and is discussed in this issue:

Sid’s created a new Pixhawk toolchain installer here: http://firmware.ardupilot.org/Tools/PX4-tools/ (see “pixhawk_toolchain_installer_latest.exe” or here’s the direct link.

The changes vs the previous installer (v14) are:

  1. updated the license file to provide links to (at least some of) the underlying component’s licenses
  2. changed install directory to Pixhawk_Toolchain
  3. updated gcc to 4.9.2
1 Like

Hi, rmackay9, I have the problem you mentionned, and I installed the “pixhawk_toolchain_installer_latest.exe” you provided. However, I have a new problem and don’t know how to solve it. I hope you can give me some advices, I am hoping for your replay!

It looks like Git is not installed on your machine or perhaps it’s not in your path?

Thank you for your reply, I reinstalled “pixhawk_toolchain” in default path and it worked, but there are also some problems.

I can get the ArduCopter-v2.px4 in the file, but it not worked when I upload the ArduCopter-v2.px4 file to the chip.

my chip is level, but the status in mission planner is not. So strange!

Sorry to trouble you again, but I believe you konw the answer!

You need to run the calibration steps

sorry for replying so late beause I see your message right now!
My problem is still unsolved, it is always calibration failed, it is so strange.

I also have this problem ,what is the reason? install the newer toolchain will be ok??

@rmackay9 I also have this problem ,what is the reason? install the newer toolchain will be ok??