Unwanted terrain following during RTL


I like to discuss the terrain following feature. With QGC and also Mission Planner I’m able to define if I want to use a rangefinder for flying a mission. In the most cases I choose the rangefinder for the full mission (included RTL). But in some cases I don’t want to use the rangefinder and I set the altitude reference to “relative to launch”. The start and also the mission work as it should be. But during the RTL the copter uses the rangefinder. This leads to partially very high altitudes above home and unwanted terrain following. Is it possible to link the RTL behavior to the rest of the mission?

Tried this parameter ?

1 Like

Yes, I know this parameter. But for my opinion it’s to complicated to change it every time when I don’t want a terrain following RTL. In Mission Planner there is a option for the altitude reference for every waypoint. It would be nice if we could also change the RTL behavior the same way.