Unstable behavior of smart audio and runcam support

I have 4.1.0beta3 flashed onto matek h743 wing . Im getting the worst result out of it .
sometimes it works , sometimes it does not . When it does respond the vtx pwr doesnt always respond the same way . Often I cant get to the lowest power settings but sometimes I can . Other times not at all .
This is not a hardware problem . Ive tried two different eachine Tx805x vtx . These have always given me
perfect , reliable smart audio performance when controlled directly from crossfire nano rx .
As far as runcam , it works one day then not the next . This hardware is on bench and is not being touched from one day to another .
Ive even tried flashing a second matek h743 and its the same problems .
The signals are coming from transmitter as required and I have run the calibrations .
This is not an issue of transmitter being to close , ive looked into that .
The relay settings are fine and the camera switching works fine
Just very unstable firmware , clearly not something Im going to put in the air .
Its fine when things just dont work but when its got a mind of its own , forget it .
I have .96 OLED screen . Whenever this decides to work the new vtx power level appears on screen . Whenever it does not I get no message at all .
I have included parameter file .
matekh743wingcrossfire.param (20.2 KB)

Please provide more information about your hardware - what runcam? what VTX? what are you using for RX? If you are using CRSF have you disabled myVTX on the transmitter.

What log messages do you get on your GCS at boot time?

Runcam split 3 micro . I’ve tried 3 different vtx , all with the same unstable behavior . Tbs unify evo pro32 , eachine tx805s , AKK x2 ultimate . The eachine vtx is proven to work fine , reliably when controlled direct from crossfire nano rx .It does not work when I attempt to control from FC .
I’m using RC11_OPTIONS=94 for vtx power control using pot s1
What pwm value corresponds to what power level and where do I enter it
For rx I’ve tried crossfire both nano and diversity nano rx . Same result
I’ve also tried rfd900x .
Also the documentation is sparse to put it mildly . Vtx options and vtx max pwr ? What is the difference , what do I enter when max pwr is 1600mw ? What am I supposed to enter for the other choices and what is going on ? There’s about 3 sentences of explanation and that’s it .
Bottom line is After a month I can’t get off the bench with this thing .
10 minutes ago the throttle stopped responding and then it started working again . I’ve tried several different MATEKH743wing wing FC and pretty much multiple of every piece of hardware . Same unstable results .
When I flash firmware 4.1.0beta3 or beta5 , makes no difference and I update mission planner to 1.3.75 I get missing parameter error .
I’m about done with this thing as no matter what I do after untold hrs of fucking with the thing it doesn’t matter .

Well, if I was in your place I wouldn’t have let this keep me from flying for a month. Why not go back to controlling the SA VTX from the RX instead if that worked for you? It’s the way I still do it, and I don’t really see any disadvantages, except for the need to set the power manually for bench or flying.

It sometimes happens that RunCam start/stop switching doesn’t work. In that case I just reboot the FC, after that it’s sure to work again, and will keep working as long as the FC is powered. I’ve never experienced unpredictable behavior using RunCam Control, and I was among the first to try it out last year.