Unexpected crash after an autotune - loss of all control

Hi all,

I’ve got an issue with my latest build. After an autotune, landing, disarming and saving of the gains I got this arming check error:


Same thing after a reboot.

After reading up on the parameter, I saw it says for AcroTrainer flight mode and will affect how quick Acro or sport mode levels in the trainer mode. If set to 1. If set to 0, it should not level in Acro trainer mode.

So I set it to 0 and my drone proceeded to go into an uncontrollable sway in seemingly only the pitch axis, right after taking off. I had no control as it seemed to ignore all my commands.

The flight logs of the autotuning looks good. No issues spotted anywhere afaik. The flight logs of the crash… No idea what’s going on in them. My stick input is clear but the drone doesn’t seem to be responding at all. As a last ditch effort I put it into acro but still no response.

Any advice would be very much appreciated as this is my first big rig!!

Autotune log: find it here: https://drive.google.com/drive/folders/14kA8HDqq9MXXzZ850ksRUNDtmUTjpa8k?usp=sharing

Crash log: find it attached to this post: 032.bin

00000032.BIN (680.3 KB)

I doubt the Auto Tune was “good” with these resulting values:

The Rate PID’s are skewed also.

Did you set the Initial Tuning Parameters 1st before performing Auto Tune? It appears unlikely as the 1st parameters shown in the guide are at default.

I would re-set to default and start over. Read thru the guide and then use the Alt>A tuning plug-in in Mission planner for the initial values.

1 Like

I will be starting from scratch and making sure everything is done by the guides. No I didn’t. Most probably that’s the cause of all of this and was easily avoidable :man_facepalming:t4::man_facepalming:t4::man_facepalming:t4:

What I meant by good is when I tested it after the completion of the autotuning, it flew great. (After autotune is done. Switching to alt hold then back to autotune to verify the PIDs. It flew great)

If this test actually used the new PIDs. Why would it not fly the exact same after being saved?

Did the autotune fail by chance or is it possible to complete an autotune with a much worse result?

I’m new to ArduCopter. I have experience mainly with arduplane.

We always just “reposition” and land + disarm while remaining in Autotune mode to ensure the new parameters are saved. This avoids confusion over whether the new params were saved or not, which ones you were actually flying with, and so on…

That’s what I did too. I confirmed in flight the PIDs after the autotune, then landed and disarmed to receive the PID gains saved message. After a reboot I had a prearm error and it would not take off until it was resolved.

The issue I see here is I did not set the required parameters before starting the autotune. This most probably lead to terrible PIDs which was only visible after a reboot.

Still doesn’t make much sense to me but I will be going through the autotune wiki step by step next week. If the same thing happens then I’m really not sure what would be the issue.

I foresee however that the same issue will not show up again.

An update:

I went out and did an autotuning again.

All wiki parameters were set correctly AFAIK, and the autotune was carried out on a slightly windy but calm day.

After the autotune completed, I switched between AltHold and autotune to test the new PIDs.

They were not good. I started seeing the exact same swaying behaviour in pitch as the first attempt.

So I discarded the autotuned PIDs and reverted to stock.

If anyone knows why this is happening, I would be very thankful for any info or advice.

I would like to tune the drone 100% so I feel safe flying a high value payload.

Logs are here: [ https://1drv.ms/f/s!Ajc7blZUQjrshEbBa5zvjlD-m0hX ]