Uncontrollable Throttle


I am at my wit’s end and need some help. My quad has a UNCONTROLABLLE throttle.

If I set the flight mode to stabilise, arm the motors, the first notch of throttle will hold the quad just within ground effect. I can confirm that the rest of the controls (pitch, roll, yaw) functions as they should. These can respond to small inputs from the transmitter

The quad is fitted with Cube Purple flight controller, T-Motor P60A 4-in-1 ESC, four T-Motor F90 KV1500 motors, Here 3 GPS, 6S LiPo, Futaba radio, and use ArduPilot and ArduCopter software.

In the 3 months that I had the quad I’ve ripped off wiring, broke a telemetry radio, destroyed 2 LiPo batteries, broke two sets of props, and had a flyaway (found it about 2 Km from home, three days later).

I’ve done the following so far:

  • Loaded the latest ArduPilot software
  • Updated firmware (ArduCopter) on the Cube
  • Calibrated the flight controller systems (several times)
  • Calibrated the ESC (several times). This was done on the individual ESC modules directly from the RC receiver as well as from the ArduPilot GCS
  • Calibrated the power curve on the Futaba radio to MAX 40%

I dropped this at my local quad shop (where I purchased most of the hardware), they had it for three weeks and could not solve the issue.

I collected the quad and tried to tweak some of the advanced settings. This seem to dampen the throttle a bit, but as I thought I was in the clear, FULL THROTTLE, dragged my tether around for a bit and hit the ground. Breaking some more props.


Post a link to a .bin flight log.


I’ve uploaded some files


Hope this helps

For starters it doesn’t look like the Initial Tuning Parameters were set. Additionally some of the parameters were changed with no apparent logic applied.
Rate P/R P&I don’t make sense.
Both the dynamic and static notch filters are enabled and not configured (at default).
PSC_ACCZ P&I are backwards.

I would suggest to reset all to default and start over. Then by setting the initial tuning parameters with Mission Planners Alt>A plug-in.

Do some Wiki reading:
Tuning Process Instructions

Thanks for getting back to me.

The config is after three months of stuffing around and having it in a dodgy shop for three weeks, did not think it was in a good condition

I followed your advice and defaulted everything, recalibrated the bits I had to and ran the Alt > A setup script as suggested.

I have not flight-tested the drone but did run the motors and they seem a lot calmer than before - no angry lions. I’ve uploaded the new .bin file of the bench test. If you don’t mind, please have a look before I break something else.


It will be much appreciated.


OK, good. Now set MOT_SPIN_MAX back to default (.95). This was never the problem.

“Dodgy shop” for sure if they made some of those parameter changes. Perhaps they are not experienced with Arducopter.

Thanks a million for your help.

I’ll take it for a test flight a bit later today and provide feedback.



The drone seems to act as a drone and not like an angry lion trying to run away.

All I need to do now is figure out why my GPS is not functioning correctly. Currently, it’s disabled to have the motor arm in the test flight but cannot fly like this - more tinkering…



I ran another short flight test this morning.

Initially, everything seems normal with good control and responses on all axis.

Then all of a sudden, FULL THROTTLE!!! Luckily I had the drone tethered else it was GONE.

I’ve uploaded the new .bin file.


New .bin file on google at d/1We8UxpxwFTPk70t9pu4oIlKNd_v4Vu23/view?usp=sharing


If it hit the end of the tether it would go full throttle.
That log link is no good.

Thanks for the update

Below are links to the last 2 log files. The second is the one that ended in the full-throttle situation

[First file] (https://drive.google.com/file/d/1rfZ4w3Zf0mWub5gnm8KnmDL-xNLdyHX9/view?usp=sharing)

[Second file] (https://drive.google.com/file/d/1rfZ4w3Zf0mWub5gnm8KnmDL-xNLdyHX9/view?usp=sharing)


You are not going to learn anything with a tether attached. Just configure and tune the craft normally.

Thanks for all your help. You’ve sorted out a lot in a very short time.

Yea I agree, I need to bite the bullet. Just a bit wary of the seemingly odd behaviour and the previous flyaway in the past


Do you have GPS? It’s not showing up in the log file and it’s enabled in the Log bitmask.

So you have a CAN GPS and don’t have it configured? You have GPS_TYPE set to 1.

yea i have a Here3 connected to can but cannot seem to get that to work

and the other CAN settings from the Hex doco.

Looking at the 2nd log…
Battery monitors - what’s going on there? Two with different battery capacities set and showing different voltages??
If the first battery monitor is correct then your 6 cell battery went down to 5 volts and will be dangerous junk now. Check the battery monitor is correct and accurate, at least for voltage. Probably take out the battery capacity settings (BATT_CAPACITY,0) until everything is working correctly and you’ve had a chance to verify that current readings are reasonable.
Set these:


Stabilise mode starts out almost OK but then maybe the craft comes up against the tether and nothing is normal then.
It looks a bit over powered so maybe add a bit of dummy payload at least for testing.
Recheck MOT_SPIN_ARM and MOT_SPIN_MIN using the MissionPlanner motor test page.
MOT_SPIN_MIN needs to be a fraction lower (or payload added) and probably MOT_SPIN_ARM should be lower provided motors can reliably start.

Get that GPS working and then set these for safety. You will wait a while for a good 3D Fix, but at least you’ll have a valid fence and you’ll know GPS assisted modes will work as they should.
Adjust the Alt and radius to suit testing and eventually up to a maximum permitted by local laws and sanity.

Set GPS_TYPE to UAVCAN. And do no flying until you see GPS active in Mission Planners HUD.

Thanks again for the detailed feedback.

I am only using power input 2 on the cube and that should be set correctley. I will verify and update both. Battery is a 1500 6S

SPIN_ARM rate is set to 100. I think the min spin rate is around 90. Anything below that does not start the motors. I’ll change that and set the and MIN_SPIN rate to SPIN_ARM +5

The GPS did function before the reset and did have solid fixes. I’ll chech it and update the sugested configs. Once that works, I can set the geo fence instead of the tether.

The motors are quite stron as it gragged my 5Kg tether anker (5L can of water) all over the place yesterday

Once I’ve made the changes, set the geo fence and have a solid gps fix, I’ll do another flight test without the tether.


OK, had a good test this afternoon without any incident until I accidentally hit the mode switch.

I’ve updated all the variables as suggested. I could not get the geofence to work and for the time being, I tethered the drone again. Everything went well until I accidentally hit the mode switch. Caught it on the tether - it really fights the resistance. Changed the mode switch back and landed a bit hard.

All in all, quite successful.

I’ll limit the mode setting to stabilise and alt hold for now and remove the other settings.

Again, I’ve uploaded the latest .bin file at https://drive.google.com/file/d/1NfOd53Phwc0oykxY2Wnw-fRRP_c6x0_s/view?usp=sharing