Uncommanded Yaw Movement rc2

I was testing rc2 today.
Autotune completed, and it never did with rc1. But, it oscillates badly w/ the auto-tune… I’ll try again before I post logs about that…

But, the reason I’m writing… I had one of those uncommanded yaw movements… A really big one… It just kept trying to spin.
I powered off the copter and powered it back on, and it still did it… Then I turned it off and did something else for a while. And when I tried it again 1/2 hour later it was fine.
I noticed in my mission planner logs, the velocity EKF went red at the time it was doing the yaw thing. But, I don’t know why.
I’d appreciate any help in figuring this out…

If others aren’t seeing the same thing, I"m wondering if I have a bad pixracer… I’ve had SOOO many problems w/ it since I got it in Jan… I’ve built 4 copters, and 3 act the same… this one w/ the pixracer is very different…

Anyway… On to the main topic, here’s a chart and a log

2016-08-12 14-43-13.bin (679.1 KB)

The logs show that the copter was rotating on its own and there was a mechanical problem. Desired Yaw was lagging behind actual Yaw and the one shot output to the motors didn’t show any high motors.


What are you looking at with the one shot?
So maybe it’s an ESC issue? That is one component (or 4) I have not tried replacing yet…

And from my view, I think des yaw is ahead of yaw… Des yaw is the green line… Which for most of the chart, is just barely in front of the red line…
So my diagnosis would be that the flight controller is telling it to turn for some unknown reason.

On my graph the red line is desired yaw which is where it wants to go and Yaw which is the green line is where it is currently. Since the Red line is behind the green line the desired it being pulled by the actual yaw.

Anyway the output is in the 100 to 250 range which is not the standard PWM output so I assume you are using OneShot ESC’s.


Thanks for testing and reporting back.
I’ve had a look at your logs and it generally looks fine except that there are large number of events logged in which the yaw is reset. I’ve asked Paul Riseborough if he can help me explain what’s going on.

The GPS quality is very poor with large velocity errors as evidenced by, large values of reported speed error from the receiver (GPA.SAcc) and large velocity innovations from the EKF. The EKF was rejecting GPS velocities for much of the time. I don’t see unusual yaw behaviour in the EKF logs.

I have tracked down the cause of the un-commanded yaw. Because the GPS was bad and produced prolonged high velocity innovations, the EKF front-end was switching between the IMU1 and IMU2 instances attempting to find a better solution. Each instance was reporting a different last reset time and yaw reset amount which caused the control loops to step the set-point each time an EKF switch occurred.

I will add some code in the front end to handle the yaw reset reporting when there has been an EKF instance switch.

Here’s the issue to track the problem. https://github.com/ArduPilot/ardupilot/issues/4679

Thanks again to @wicked1 for the good report!

Hi, thanks for looking at my logs.

Can we get any clues about what the issue is with the GPS from what’s in the logs?
Simply bad reception, or could it be a physical problem?
I have this issue often on this copter… But as I mentioned, it seems random… I can turn off the copter for a few minutes and start it up and the issue is gone… But then maybe a few flights later it happens again.
I’ve actually already replaced the GPS, but it was with one of the same model… (but it’s csg shop, which usually gets good reviews).

If anyone has any ideas, I’d appreciate hearing them.

It happens also to me but not only for Yaw but also with Altitude and then I got no control anymore .

Here the post

Very dangerous behavior a copter that do not respond anymore to radio commands and just do what he (EKF ?) thinks is better .

@lucamax Stop cross posting please. Your issue is in another version, it has nothing to do with this thread.