Unable to make a proper flight with my QuadC

I am new to the hobby and have my first quadcopter self built. The frame is the X525 equipped with 4 SUNNYSKY X2212 980KV Brushless Motor + 4x 30A Mystery ESC driving 4 10x6E propellers or 10x4.7propeller (I tried both setups). The Flight controller is the APM2.6 and is loaded with the 3.1.4. firmware. My battery is 5Ahr 35C-70C.
Now to the problem. I tried the initial setup in the Mission Planner by doing the Radio calibration and also the Accelerometer calibration. My Qcopter does lift but is never stable. It drifts, moves to one side. When I start giving thrust to the motors, they do not start simultaneously. I used the trimmers on my transmitter (Tx) but they still have some minor difference. That make the quadcopter lifting with a tendency to move to the opposite of the quicker motor. I tried to fix this by the sticks of the Tx but is almost impossible to stabilize it.
Can anyone direct me to what I am doing wrong? I must be miss something but cannot find out what. I tried 3 flight modes, Stabilized, loiter and acro. Only stabilized is capable of a few seconds of flight, the rest have quick sideways drifts.

Providing tlogs and/or data flash logs will great help to troubleshoot your issue.

Hello TCIII, thanks for the reply. The log is attached. I don’t know if I provided what is needed. I hope it would be fine.


Did you calibrate the ESC’s? It sounds like that might be the issue. If you did I would try it again. Here is a link with instructions on how to calibrate the ESC’s. Hope this helps.

copter.ardupilot.com/wiki/initia … esc-motor/