Unable to hold position during position hold

Hello everyone,
sir i am stuck with a problem when set on position hold.i am using 4.0.3 version and when i put my drone on position hold it only maintain its height and moves in random direction. when i saw logs, the mode is changing but unable to maintain its position.I am using Here gps. https://drive.google.com/file/d/19fN0mHdC4fQpFcRppp_Y3FBNH9kJX94e/view?usp=sharing

In the vibration logs ok, Err ATT ok, you started with only 8 satellites, but then gps ok. Try to calibrate the compass - there are large positioning errors indicating most likely a calibrated compass. You have a very small hovering throttle. 0.12 is too low for everything great worked. Reduce the size of the propellers or reduce the number of lipo cells. At the time of turning on poshold the height was negative … Try after blocking the gps fly a moment in althold and then switch to poshold … I hope it’s a compass …

check if the compass orientation is ok

as u said, i calibrated the compass again and fly the drone.I found something interesting that when i put the drone on position hold it behaves same as before,moving in random direction but after 4-5 minutes it set its position.I am confuse am unable to target any error.kindly reply

please send me a param file and write what drone it is (what engines, propeller size, weight, frame type). Does it hold the position in Loiter mode?
You may need to set filters, pids, a kalman filter better than you have - I will try to help.
Did you do the autotune?

For future reference you can easily extract a parameter file from a …bin log

Hy I Using 3 cell,propeller size 7038,frame type-X,total weight=650gram.
Parameter file : https://drive.google.com/file/d/1Qk2JlfBwucEKkFbrtMtULdH6tR3EjsVE/view?usp=sharing

no i didn’t use loiter mode nor i did autotune

It indicates a wrong magnetometer, i managed to solve this kind of problem by replacing compass.

1 Like

i tried it with different gps with external compass but same behavior.

Maybe the position of the compass is bad?

The parameter file shows no device ID’s for any compass. At some point one must have been active because there are offsets listed but none are working now. Post the parameter file with the different GPS/compass module.

Kindly check ,it includes all the things that you want

There is an AK09916 compass being recognized now. What module are you using?

I checked the compass interference ok, engines 1255,1273,1345,1322 on average. Set esc type to 0. Unless you are using blheis regulators, the hovering on such a low throttle will not look good on PWM. Switch to oneshot or dshot (as you can), add 200g of weight to the drone for test and see what will happen .After turning on the power, wait 5 minutes, then start in alt hold and after at least 30 seconds switch to pozhold. If you have an old simonK esc type, then on a low throttle at which your drone floats there is a long delay and poor linearity. Try to use oneshot after calibration and add mass test or . decrease by 1s aku.Do imu interference test and set notch filter, perform autotune and check if it helped

Write also what you normally expect after pozhold, because Google maps show poor the stadium where you flew in India, and you moved RC in and I can not estimate your errors in position.