Unable to get "sonarrange" when rangefinder is facing up

I’ve build a quadcopter that has to fly indoor, if put a TeraRanger Evo Mini facing up so I can use simple object avoidance to not crash into the celing as described here.
I’ve configured all the parameters like this:

Range finder configuration:

  • RNGND1_ADDR: 49
  • RNGND1_MAX_CM: 300
  • RNGND1_MIN_CM: 3
  • RNGND1_ORIENT: 24 (Facing up)
  • RNGND1_TYPE: 14

Colision avoidance configuration, described here.
https://ardupilot.org/copter/docs/common-simple-object-avoidance.html for AltHold

  • AVOID_DIST_MAX: 2 (So it stops at 2m from de ceiling)

And the thing is that once I have all this configured, as far as I’ve read, it should be good to go, but if I go to the initial page of Mission Planner and look for the sonarrange parameter it doesn’t show up, but if I set the ORIENT to 25, down, it shows a correct distance (to the ceiling), is this normal?

Thank you.

Probably Mission planner is only showing the down range.

To make sure it is working fine you will need to test it in SITL.

Thank you for your help, looking in the GitHub repository of MissionPlanner i’ve find this PR https://github.com/ArduPilot/MissionPlanner/pull/2151 it seems so, looking at the code of the PR I guess I will have to look to the rangefinder1 value.