Unable to find crash cause!

Hello all.

I have searched the forum to find a similar issue but can not find one.

I had a strange crash during takeoff today and I have tried my very best to find the cause studying the logs. However I am not sure of anything.
Recent changes from previous flight:

  1. Used a second gps which was at float rtk status while takeoff.
  2. Turned on servo auto trim.
  3. Limited my power output to 1000 watts.
  4. Changed battery to a custom li ion battery.
  5. Manually trim throttle as esc was not being calibrated with the procedure mentioned in the wiki.
  6. Tried takeoff at 40 amp current whereas previously it took off using 60 amp current.
  7. Right at takeoff, for the ekf gps usage, the 2nd gps went from rtk float to first gps 3d fix.

It is a twin motor setup with AUW of 4000g and a v tail.

My guess is low power while trying to take off. But just need a confirmation.

Is there a procedure i can follow to diagnose the faults myself?

Logs for both flights can be found here.