Servers by jDrones

Unable to change mode to Auto and Take off


(Nicoalshu) #1

Recently, I was testing my Align 600, and I wanted to fly a mission. After ARMED , I couldn’t switch to Auto mode. Mission Planner HUD show change mode failed . I can only take off manually and switch the Auto mode in the air,and fly a mission.Then I Analysis log,this is the error


If you meet the same problem, would you help me?. I will thank you very much
image


(Shawn) #2

I think your mission would need to start with a takeoff command and altitude. If that’s not the issue then set log disarmed, run the test again then post the bin log here.


(Nicoalshu) #4

Thanks for your replay! !


I had tested this mission on my Quad ,it succeeded in taking off and fly a mission.But I tested the same mission .After ARMED , I couldn’t switch to Auto mode. I also found a problem. When my Helicopter take off ,my Mission Planner reminded me that “Failed to update home location(1)”.As shown in the following figure: !


(Nicoalshu) #5

How to set log disarmed?From" Full Parameter list"?


(Chris Olson) #6

With helicopters you must wait until the runup timer expires before switching flight modes. Recommended to start from Stabilize so the Loiter controller doesn’t try to tip it over during runup. NEVER use auto takeoff on a slanted surface. Only a human pilot can handle that. When the runup timer expires, then switch to Auto.