Unable to calibrate ESC's on 3dr x8 with Pixhawk1

I’ve tried calibrating my ESC’s using Mission Planner’s Unplug and plug in method, or also the common technique for all at once ESC calibration where you start the model with the throttle all the way up, then again and press the safety switch, then down… When I try either procedure, I am unable to get any beeping responses or any calibrating going on as far as I can tell. Sometimes when trying, my Pixhawk will blink continuously red & blue, but a reboot solves it to try again.

The motors do start at what looks to be the same time, but then when I go above 50% throttle and back down and watch the servo outputs, there is quite a bit of variation. Sometimes I even get the audible from Mission Planner “crashed,” followed by, “disarmed.”

What could be causing me to not be able to calibrate? Are these pre-calibrated ESC’s? They are the SimonK’s, I am pretty sure.


Re the motors not slowing down at the same time, the issue is probably that the vehicle is trying to control it’s heading but is unable to because it’s not actually flying. The “crashed” message is similar, it’s trying to control it’s attitude but is unable to and determines that it has crashed. I wouldn’t worry about these two issues very much.

The best way to test the motors start at the same time is to use MP’s motor test.

Re calibrating the ESCs, many ESCs act differently so it is difficult to provide advice.

By the way in Copter-4.0.x you may need to manually set the ESC_CAL = 1 before you can use the hight-throttle-at-startup method. The mission planner’s Setup >> Mandatory Hardware >> ESC Calibration page works the same as in 3.6.x though (i.e. not need to change ESC_CAL manually).

Have you successfully been able to calibrate the ESCs using an older version of ArduPilot or is this the first time you’ve tried? Presumably you’ve got Copter-4.0 on the vehicle?

1 Like

I think you’re right (seems right from playing with it) about the motors not slowing down at the same rate being because it’s trying to stabilize/maintain hover… Having never actually flown a Pixhawk controlled craft, it’s good to get an affirmation.

As for the motor test, yes, my motor tests work fine. When I first got the mostly assembled and setup craft (the 3dr x8,) motor tests would start them all at different percentages of input power via Mission Planner, but somewhere in my configuring, I think I must’ve actually succeeded in calibrating the ESC’s. They all start at the same time and all increase speeds at what seems like the same speed too.

I tried out the options change in copter 4 (what I am using) and it did not seem to change anything for me. I tried several options, actually; recalibrate if throttle up, recalibrate no matter what, recalibrate on next restart… All of them No change for me.

I think they’re calibrated because of the drastic difference from before I started. I’ve adjusted my hover thrust to be about .38 (down from (.5ish) and I think I will put the propellers on and do some low almost takeoffs and maybe a low takeoff or two, just to see it in the air. It’s too cold for autotuning where I am right now. Has been down around 0-5 degrees celsius lately, and why I figured wintertime would also be a good time for building.

Went to put the props on… no nuts :slight_smile: I guess it will give me time to decide which size propellers I should use on my x8+. Standard it came with are 11" props, and I’ve got one set of those. What I don’t know is why it came with 39 pairs 0f 10" props as well. It makes me think the previous owner found them to work better. I imagine the 10" props would help it fly more precisely and possibly put less strain on the motors/ESC’s. I know the previous owner was also flying at high altitudes, so this doesn’t make a lot of sense to me why else they would stock up so heavily on the 10" props, unless it was for more precision. I’ll probably autotune with the 10" props, but… any recommendations as to prop size on the x8+ from someone who’s flown it?

1 Like