Tuning is Not Going Well

Hi Folks.

So I am not really making any progress in tuning my new airframe… My old Skywalker 1900 eventually decided it couldn’t handle the pressure anymore and autopiloted into the ground - some resin from a previous repair blocked up the pilot tube resulting in a mid air stall and a crash…

So version 2… well, version 3 actually. Version 1 hated me so much it just flew away. Version 3 is a 1900 Skywalker (the one with the carbon fiber tail boom).
Turnigy aerodrive SK3 3542 1000kv motor with a 9x6e prop.
70amp esc.
FrSky D4R2.
9X transmitter.
Pixhawk with external compass and uBlox GPS.
Pixhawk digital Airspeed sensor (with the resin now cleaned out)
5000mah battery.
Fiberglass repairs and reinforcing.
Payload is a little cannon SX260 camera.

Right, so off the bat I have always had a problem with the rudder: it moves further to one side than the other. I fixed this by adjusting the end points in the transmitter so that full left and full right on the sticks gave the same amount of movement… I have a suspicion this is one of the problems with my setup but I’ll get to that…

I have tuned the airspeed sensor as per the instructions using auto calibrate and it appears to be reading correctly. Before each and every flight I redo my compass offsets using the live calibration and the “place plane like X and press any key”.

Four days ago I attempted to do the autotune… it went OK but the parameters did not change all that much. I suspected it was because I didn’t hold the stick over in the roll for long enough.
So three days ago I did it again. This time I tried to keep the sick at max for two seconds on each iteration. The figures changed a bit more and I did much rejoicing becuase she was responding a lot better in FBWA and not flying like a wild horse in AUTO.

However, I was losing altitude on turns. Up to 10m. So I went ahead and increased the rudder mixing and went to work on the YAW2SRV_RLL parameter as per the yaw tuning guide… but I made things worse.

So now when I bank right I lose dangerous amounts of altitude and when I bank left it appears to gain altitude. In short, it simply is not behaving correctly and I am too scared to throw it into a RTL or AUTO mode for fear of another crash and more fiberglass work which is not nice.

Please oh please could someone have a look at my log file and help me out a bit - give me nudge in the right direction, anything. I am at the point that I shake with fear and my heart pounds every second that the plane is in the air!

Oh, and also, I cannot download the dataflash logs? Haven’t been able to since about last year June I think. I have the BITMASK set to the pixhawk defaults and I am doing the “download logs via mavlink” but it just says “Failed to get Log” or some such business…

EDIT: My logfile is too big so here is a dropbox link:
dropbox.com/s/wqw527eejv1gb … 2.zip?dl=0
Sorry about the length of it. This was from yesterday and I think I did two or three flights with a bit of waiting around in between launches - it was a nice day so I was trying to relax.

My tuning went from bad to catastrophic as my Pixhawk now no longer feels the need to control anything anymore… see this other topic:

So, if anyone wants to chip in there too that would be great…

This really sucks… :cry:

It would seem that my hardware problems might be related to the ESC. I’ve yet to confirm but will do as soon as I can get my hands on a working ESC.

On the meantime, has anyone had a look at my log files? Things are very dangerous in auto modes. I absolutely have to fly in manual or FBWA or I risk crashing again.