Servers by jDrones

Troubleshooting help, I2C Bus dead

Heya,

was out tuning a new Arduplane (3.5) system, did a quick auto mission and bought it back in to land and change some settings. Plane had over an hours air time previous to this, and everything was behaving itself. Logs look good, nice Vcc at 5.2v (Mauch HybBEC).

Didnt cycle power once landed, tweaked Nav L1 radius etc. Went to rearm and relaunch and MP spat out a compass not calibrated error on trying to arm. Very curious.

Tried again, Airspeed error.

So we powered down and rebooted the system, and it refused to arm due to Airspeed errors. Tried again, same deal.

Plugged into USB (remote socket) and USB will not power the system. Got a lil click click noise out of beeper then dead. Remote USB does nothing now. If I power the system from flight packs, and plug USB into it I get no response from PC, but remote LEDs faintly glow.

Plugged into USB on the pixhawk itself, boots fine under USB power, but everything on the I2C bus is dead as a doorknob, no airspeed, compass is swinging in circles.

Checking with a multimeter on I2C pins i have Vcc voltage, so its not power.

Logs look fine, however is only set to log when armed and whatever died appears to have died while disarmed.

Since the bus is essentially dead now I cant play swap components to see if its a certain unit that has bought the system down, so am not sure if I replace the pixhawk the same thing is going to happen again to replacement pixhawk.

Any troubleshooting ideas? Ive never seen this happen before, so am curious as to what happened.

Bit of a follow up -

Remote USB is dead as doorknob, doesnt work on another pixhawk. I2C LEDs on it are also dead.

Airspeed sensor is dead.

External Compass appears fine now, it wasnt getting power from I2C though

I2C bus on this pixhawk appears to be alive again, but unit is going in the dead bits box :cry:

Something very peculiar happened, have no idea what caused what though :mrgreen:

Servers by jDrones