Troubles with my pixracer ArduPilot! Oscillations and other issues

Hi all,
I am currently building a 7-8" quadcopter, and I am having some issues that I just cannot seem to sort out. I have tried seeking some help on multirotor pages on FB, but to no avail.

A little bit about the copter, it is a custom built (3D printed nearly everything in a lab)
it is running a PixRacer mPro R14 auto pilot, with ArduPilot, and a 3s 3000mah lipo battery. I have set the aircraft up with a mixture of Mission Planner and Qground Control.

My problem is, I cannot get this plane to One: Stop drifting everywhere or hold altitude very well, no matter how many times I recal the compass, accel, etc. I fly it in stablize, loiter mode, as well as altitude hold. It seems as tho the throttle curve might be goofy but I am unsure how to fix that. When i throttle up, the plane climbs and I have to throttle down to get it to come back down (as in it keeps climbing and wont just hover, no matter where i sit the throttle) it will usually begin to descend and then I will have to apply more power to get it back up, and then repeat with descend.

Secondly, it has a bad oscillation when it is “somewhat” hovering, almost like each motor is speeding up and slowing down in sequential order. it looks to me like the PID loops may be wonky but, the last time I tried to do the PID auto tune with it, it did not seem to cure the problem at all. At the time, I was using E38 mission planner, and my PID loops all said 0, and were greyed out so that I could not change them. I recently uninstalled e38 and downloaded the newest MP version, and my PID loops are actually changeable and all set at 4.5 currently. So, should I try the auto tune again?

this is my first quad I’ve built myself so I am a bit lost here, I am not new to drones at all but I typically fly a COTS system like a trimble fixed wing, or a DJi or whatever it may be, during autonomous data collection missions.

Thanks in advance!

Post a flight log to get assistance here.

So this is a new aircraft that has never flown before and is of your own design? If so it would be good to verify the mechanical and electrical properties and make sure these are correct before thinking about the PID parameters.

Likey you have build it all correctly but this needs to be verified. For example what ifthe power supply internal resistance is high? Then yu throttle up the motors and the voltage sags. THis is easy to get wrong if the motors are large and the battery’s “C” rating is to low. or the wire is some smal. So you might describe the copter is some detail and give the weight with battery. In general you want to start out with a copter that is stable and can hover out of ground effect on 1/2 throttle. A machine like that will give the control software an easy job.

I may get stones and arrows thrown at me for saying this but if the copter design is new and not copied from a known to work design you are best to try the first few flights using a BetaFlight or CleanFlight on the flight controller and fly the copter manually. This gives you a better feel for how well it works and lets you see right away if there are unusual problems and to learn where the throttle setting is for hover.

I’d verify that the copter works manually using a manual flight controller mode before I’d try position hold.

So just maybe the copter is marginal and the autopilot tries to keep the postion in light wind but can’t increase power (power is needed because of the tilt into the wind) and the copter drops, dropping addsair through t prop increasing thrust… You see cycles. But I am toally guessing

Try 100% manual flight and see what you need to do. If you need to put the throttle at 85% to hover you wil have big problems later.

1 Like

thank you guys for the advice, I will try to get a flight up today to grab a log and post it here for you to view.
As for the copter, I did not personally build it myself, I am collaborating with a team of Engineers on this project, and I believe they along with the person that I replaced on the team built it and verified everything you talked about, but I will check and see what was verified and what wasn’t. this quad is part of a design contract so it is not an off the shelf system or one that has been built before, but it is very similar to other 7-8" quads.

I can tell you now the specs that I know, and follow up in a bit with whatever else I find.

on top of the Pixracer R14 with ArduPilot

  • the motors are T-motor F40 Pro II (kv1600)
  • the ESC is a 4 in 1, I believe a 35A but I am unsure as there are no visible markings on it, but we have another identical quadcopter to it that has a 35A x4 Lumenier ESC board.
    -the props are 9x3.8sf

I am flying this with a Spektrum DX9 transmitter and a spektrum FPV racing serial autobind receiver

The battery is a 3s, 3000mah multistar 3.0 by turnigy.

I’m not sure if any of this helps but that’s what I have so far, I will try and get a log for you guys today!

Thank you so much

Hi again guys,
Okay, bad day so far… Here is the log file from the flight I just did which ended in a crash.
I got the quadcopter in the air, it was oscillating as per usual but it was flying and was controllable (just like it has been before, and I have been able to fly it manually)

I put the copter into auto tune mode and let it start doing it’s thing, it was drifting around a bit but I was able to bring it back and let it continue.
Around 6-7 minutes into the auto tune process, I thought I heard something coming from the copter (maybe a screech?) and it went into a full 360 spin and began flying around in that full rotation until i cut power and it dug itself into the dirt.
I’m not really sure what happened, the props are still on, it looks like one of them is loose but I’m not sure if that happened during the flight and caused the crash, or if it came loose after the hard impact.

I have the quad plugged into my computer now on mission planner and it’s now telling me the compasses are inconsistent… Which I imagine may be from the crash because they were calibrated before and gave me no errors.

Any insight you guys can provide from these log files would be great,


Hi Dave,
I included the binary and DF logs at the bottom of the replies as a dropbox link, is that what you are looking for? if not just let me know and I can link whatever else you need.


Yes, those are the right log files but man is that craft unstable. The motor oscillation is clearly seen in the RCout data. I would have thought it was a vibration issue but that’s not the case. On smaller quads with Pixarcers the Rate Pitch/Roll filter setting have to be raised from default 20Hz to ~40Hz (ATC_RAT_PIT_FILT & ATC_RAT_RLL_FILT). Also the Accel and Gyro filters have to be raised (30 and 60 Hz respectively, INS_ACCEL_FILTER & INS_GYRO_FILTER). These are suitable for a 250 size quad so for your craft they might be a bit high. Worth trying though IMO.

Also I would disable compass 2&3 and just use the external compass. I have found the internal compass’s on a PixRacer to be nothing but trouble and I have 3 of them. You will likely be plagued with “compass inconsistent” errors otherwise.

That is the most helpful info I’ve been given so far! I appreciate it a lot. I will check those paramaters out and also disable the other two compasses. Being that my quad i bigger than a 250, would you think to set my Rate pitch/roll filter inbetween 10-20hz to 15 or so? or should I just try 20 and then work my way down?
Yes it is super unstable currently, I honestly thought it was just a bad PID base tune but that doesn’t seem to be the case!


Hi again Dave,
I was just looking through the Params, and the Rate Pitch / roll params you had mentioned in your previous post are actually already raised to 20HZ in both cases. I did however change the INS_ACCEL_FILTER to 30 and the INS_GYRO_FILTER to 60hz like you had suggested. And I also disabled compasses 2 and 3 like you had suggested as well.

Is there anything else you can think of I should change?
Thank you!

Sorry Nik I should have said raise those filter settings from 20hz default to 40hz then give it a go. You may have to drop the D term PID value also but try these filter changes 1st to see if it improves in general.

Your point about splitting the difference between what works for a 250 and a larger craft may be valid. I have a large quad with a Piracer that flies OK on default params. You could try that 1st I suppose.

Hey Dave that’s no problem, but just so I am clear, you are saying to raise the ATC_RAT_RLL_FILT and the ATC_RATPIT_FILT both to 40hz? Or am I reading it wrong.

thanks for all your help!

Nik-Yes that’s right. I corrected my previous post so as not to throw anyone else off!

Excellent advice, thank you.
I’m going to get this stuff changed and try to get out for a test flight today to see how it flies now, hopefully it will be better.

Oh also Dave,
I wanted to ask what your suggestion might be for the quadcopter overshooting my throttle and descend inputs, I know Chris suggested flashing beta flight and running it in manual mode, and that’s an option but one that I would prefer to avoid if at all possible. Aside from the drifting and oscillations it has been having, I just cannot get it to hold an altitude very well and it over shoots my throttle and descend inputs by a long shot every time.

No stone or arrows thrown but there is no Betaflight firmware target for Pixracer. Arducopter, iNav or PX4. Just stick with Arducopter and work thru the issues. I would concentrate on stable flight 1st and maybe your other problems will go away.

Good idea, I will see what happens. Also, you mentioned possibly having to drop down the D term PID value, which one are you referencing exactly? the D value in Pitch PID? or Roll? I just wasn’t clear on that specifically.

I have had to lower both quite a bit on the smaller quads. Depending on your setup probably not equally. If you get it flying close to stable you can try Auto tune again just be sure to save your parameter file beforehand in case its not good.

Okay that makes sense, I mean, what is a low number for those?

.001 or almost zero. I suspect you won’t have to go that low. Do you know how to do in-flight tuning with chan 6 options?

I haven’t tried it yet, I saw some documentation on Mission Planner’s website but I’m not really sure how it works other than just telling the chan 6 knob to do the tuning.