Trouble with TeraBee Evo


A TeraBee Evo 60m rangefinder was laying around and we wanted to try it out with our mRo Control Zero flight controller.

We read the following docs:

We connected the rangefinder to the flight controller using the I2C ports shown in the image below highlighted in yellow. We also set the following parameters:

  • RNGFND1_MAX_CM: 6000
  • RNGFND1_MIN_CM: 50
  • RNGFND1_ADDR: 49
  • RNGFND1_TYPE: 14

We also tried connecting the rangefinder to the USART highlighted in green.

When testing the sensor with Mission Planner, the “sonarrange” does not change (always 0).

We also powered the RF with an external battery. Same result.

Any suggestions on what to try next?

Thank you for your time


Good day,
you are trying connect a single sensor or the evo hub with all the sensors to the fc?

Hello @Dave84 ,

We are connecting a single downward facing TeraRanger Evo directly to the FC using the included I2C backboard.

Did you check the correct pinout from the back board of the sensor?

Yes, we did. We used the pinouts below. The power led is on the rangefinder is on. We even tried swapping the signal wires just in case.

We also tried using different flight controllers (mRo Pixhawk 2.4.6 and Radiolink PixHawk) Both were connected to the I2C port.

In all cases, still no readings unfortunately.

it’s weird… do you mind write pls the parameters you have set

We set the following parameters for all the cases mentioned above:


Since it appears you can connect the sensor to a serial interface, is it possible to use a USB-serial adapter (like an FTDI adapter) and directly monitor the serial output? Perhaps you’ve simply got some bad hardware, but it might prove difficult to narrow the cause down to that if you can’t test the sensor on something other than a flight controller.


We used the device below to connect the rangefinder to a laptop.

We were using TeraBee’s TeraRanger Evo GUI to check its function. It wouldn’t detect the device.

They also list software, as you said, to directly monitor the serial output called HTerm. I’ll give it a try.

Then you have a hardware problem and probably shouldn’t even try connecting it to the flight controller until you solve it.

Most often, the problem is the meat interface between the hardware subsystems (i.e., you…or me). It’s very easy to mistakenly reverse the RX and TX pins, in which case, no detection, input, or output is possible. Fortunately, it’s also not (usually) harmful to reverse that connection, so try swapping those pins first. DO NOT accidently swap power and ground, lest you release the one-time-use magic smoke contained within every electronic component.

Parameters seems ok… how about the final cable for connect it to the flight controller?

I’m sorry, I’m not sure what you mean.

When using the I2C port on the mRo Control Zero or even the mRo Pixhawk 2.4.6, I connect the following as the documentation stated.

  • Vcc to Vcc
  • Gnd to Gnd
  • Sda to sda
  • Scl to Scl

For the control zero I also connected after trying without

  • Tx to Rx
  • Rx to Tx

Simply put, if you tried two different protocols on three different devices and are certain you wired it correctly each time, the sensor is broken.

Later i will do some test with mine… but probably your sensors it’s faulty

Thanks for your time.

I’ll update if I get it working.

Did you manage to make it work? I’m very interested since I want to use a EVO 60m aswell
Thanks in advance