Servers by jDrones

Trouble trying to flash Matek H743 with ardupilot (solved)

Hello my arducopter friends hope all is good im trying to flash the Matek board with ardupilot but it just wont connect ive tried stm cube and impluse when I connect the board it shows DFU SF in device manager on stm cube is says no dfu and on impluse I get a message code 16,any help will be greatly appreciated and thank you

The process described on the Matek Site using the STM32 Cube Programmer works for me:
STM32
Click the link in there for DFU drivers. I used the ImpulseRC Driver Fixer as I recall. You may have to do this if you have tried and failed with iNav or BetaFlight configurators.
If you want to follow a video there is one on the Matek site after clicking the “Firmwares” button.

1 Like

thanks Dave will try again

I was wondering if you flash it once can you flash it back to Beta flight? if that makes sense.

1 Like

Hi Brandon the problem is i cant flash it ive flashed Matek 405 ctrs before no probs this little devil wont do any thing and when I look in device manager it says DFU SF ive cocked up somewere and how the devil are you

Doing well! I did read something about not pre flashing some settings. can’t recall what it was tho.

1 Like

this thing is driving me batty my half a brain cell is now totally defunct dont no about DFU

Try dfu-util - works every time for me and there are builds for all platforms

2 Likes

Thank’s Andy,will give it a try and hope you and family are all wel

Easily back to Betaflight or iNav.

2 Likes

it just seems stuck in DFU SF I am just going to try a 405ctr board and thanks

Hi lads think it is my lap top just tried the 405 board and the same and error code 16 if that means any thing to you guy’s

This morning managed to solve the flashing after a bit of messing about got the STM bootloader in device manager more luck I think,then use the STM cube to load ardupilot so happy camper am I thanks every one for your help,have a nice day

Hi @MartyMcFly,
I am glad to hear that you have solved the problem. Is this because of laptop problem? You did change the laptop? Or is this Windows 10 problem…I am curious to kow, as I just ordered the same Matek H743 for my Quadplane.
Regards…

1 Like

I changed over to a very old windows 8 computer it still took a few times to get it to connect with SMT Cube programmer but once connected super easy i need to do an F405wse at some point

Servers by jDrones