Trouble firmware download

When trying to update firmware (arducopter 3.3 or 3.4) I get failed to upload… Tried three computers and all with the latest Mission Planner. Anyone else having issues?

The firmware server seems to be slow, I’ve asked the appropriate people to look at it. Sorry for the inconvenience.

P.S.: Please don’t double post the same issue.

Your board is a Pixracer? I had to do it two or three times to get sucsess, try with another wire too.

No, just an old Pixhawk. Tried multiple cables as well.

Sorry about the double post. I thought my first message failed. Didn’t repost here because I though it would be more appropriate in the MP forum. And there it is, posted anyhow. My bad.

No problem.

Just to make sure: your problem is downloading the firmware, not uploading to the Pixhawk right?

The firmware server seems to be working good now. If you still have problems you can try to download it yourself and then upload with MP:

Those links are for Pixhawk, don’t use them for other boards