Tricopter Yaw servo not working

I recently built a tricopter, but when I attached the tail servo it went to the maximum position and eventually burned out. I tried adjusting the minimum, maximum, and trim values for it but that did not help. I tested the servo using an RC receiver and it worked fine. My tricopter is running the latest version of Arducopter on an erlebrain2.

Any ideas on what is wrong?

Thank you

Don’t know about erlebrain, but I have a tri with pixhawk and arducopter 3.4rc1. If your hw connections are fine, you should control the limits by setting MOT_YAW_SV_MIN and MAX. The servo should be connected on ch7 output.

When your copter is ready ( power switch disabled, led steady ) if you change those parameters you should see the servo moving accordingly. Please test with the propellers off.


I tried changing those values, but it did not help. The max and min values currently match the maximum and minimum values that the transmitter goes to. As soon as Arducopter starts the servo still tries to go beyond its limit and makes a bad noise.


Is it connected to ch7 , right?

How is the value of ch7out in Mission planner’s status tab? is it outside the range of your RC? Do you have a safety switch setup ? Mine only enables the output channels when i disable the safety switch - not when arducopter starts.

Could you please post a logfile with log_disarmed enabled?