Servers by jDrones

Trex 600 stretched (700) Pixhawk 3DR tuning

(Ozzy ) #85

I think the problem with the frame itself,
I was able to twist the frame left and right easily when the heli set on the skids

Also if I twisted like fish tail it shake also

And that Because the spacers (35mm) long can make the frame more flex

When the blades rotate it will transfer the vibration to Y axis and make the bottom shake more !

I wish I can place the FC in front where is the batteries
But the problem with the CG; the heli will tip back as the tail will be super heavy !

I am thinking of mount it on the side of the frame but how to calibrate the FC if I do this ?

Thank you
Ozzy

(Ozzy ) #86

What about putting back where is the Hobbywing ESC now ?

I tried that location before with my old FC long time and was interfering with servos !

But it’s more ridged than the current one

Thank you
Ozzy

(Bill Geyer) #87

You can calibrate the flight controller if it is mounted sideways on the frame. I believe it has a way to determine it automatically and you could also set it with one of the parameters. I’m sure you can find the set up information in the wiki. It is discussed here

(FRED GOEDDERT) #88

I am not sure but I remember to have seen a note somewhere that the cube cannot handle to be mounted on its side like the Pixhawk v1 could. I believe Chris Olson found that out. Not sure. But if you have time I would try it to see the outcome.

(Ozzy ) #89

Guys, I mounted the FC inside the frame… using double side 3M tape only, just two pieces front and back of the unit, no movement …

the test was with few Check mag field problems because its close to the motor and the tail servo…
but what I see from the VIB; it went down to 5!!

but I just don’t know about the other (RATE) if its still problem or not!

I am thinking maybe using little softer mounting tape to give it little movement ( like double side thin 3M foam) ( I see at the HOME DEPOT they got white double side foam tape to attach mirrors to the wall!

maybe I can get it better in the (RATE P and R )
here are the Bin and the LOGs

Thank you so much
Ozzy

(Bill Geyer) #90

Ozzy, you shouldn’t get any mag field problems. Because you should not be using the compass in the pixhawk. You should only be using the compass in the GPS unit

(Ozzy ) #91

Oh you right! I forget that !

Maybe because I was close to the grass and was so wet ! That was the only thing I am thinking about, once I take the heli inside no mag problems at all!

But what do think is it better location regard the vibration ?

Thanks a lot
Ozzy

(Bill Geyer) #92

Where did you calibrate the compass is inside or outside?

(Ozzy ) #93

I calibrate it outside, before I mount it in the heli

the offsets X:120, Y:45, Z:22

is that 120 is high?

I can take it out of the heli and re calibrate it if its not good .

Thank you

(Chris Khosravi) #94

Someone correct me if I’m wrong but you should do the calibration while it is installed in the helicopter. It needs to be able to characterize your mag field produced by the helicopter so that it knows how to calculate the true magnetic heading.

(Ozzy ) #95

Chris
I will calibrate the heli whiteout taking the FC out today maybe I can get better offsets numbers

But my question is; do I need to do that every-time I change the location of the FC?

I know that FC’s GPS is disable and the external GPS is the one active, so I don’t need to calibrate Compass every time I change the location .

But the gyro maybe effected since the location of the FC change !!

But I think as long as heading to the front and no change in the direction then we should not need to calibrate it either!

Thank you
Ozzy

(Chris Khosravi) #96

If I were you since you are learning, I would redo all calibrations every time you move the FC. It doesn’t hurt anything to redo things. Cutting corners is not something you should be doing since you are constantly having trouble. Helicopters in general are not something you can be lazy or sloppy with.

(Ozzy ) #97

I totally agree!
Trust me without your guys, I can’t go one more step !!

You are a big help !
I will recalibrate it…

Just want to ask about your heli,
I know you use gasser heli and the gasser helis have more vibration than electric

How you control that vibration ?

I also see you use electric helis too

How you mount, where and what do you use to damp the vibration ?

It will be really helpful to me and others want to learn how to deal with this ghost ( vibration )

Maybe you use different components in the heli ?
I replaced everything in the heli and still have vibration !!!

Edit ;
Can you please if you don’t mind post pics of the good vibration level and the (Rate P and R) so I know what a good vibration level is, and what a good RATE att P and att R are good to compare with daily tuning?

Low frequency oscillation and high frequency

I appreciate your inputs
Ozzy

(Bill Geyer) #98

Ozzy,
You missed some settings when you transferred to the Pixhawk 2.1.

INS_GYRO_FILTER 10
ATC_ANG_PIT_P 6
INS_FAST_SAMPLE 0
INS_LOG_BAT_MASK 1

Your altitude looks good. I would say you can make these changes. Fly in stabilize to make sure it feel ok. By the way what did you think of the lower Accel and higher input_tc values.

After you fly in stabilize then you can try loiter.

(Ozzy ) #99

Oh yeah I forget those changes

I will change them and fly it with Stab and loiter

After lowering the Accel and higher input_tc value the heli was better but still fast respond touchy little bit.

If I was not experienced pilot, new pilots may get lost with the direction when it turn in front of the pilot ! And since it’s sensitive to the inputs; will end with crash …

Thank you

(Ozzy ) #100

Hi,

after changing the values;
INS_GYRO_FILTER 10
ATC_ANG_PIT_P 6
INS_FAST_SAMPLE 0
INS_LOG_BAT_MASK 1

I flew the heli and it was good.
I don’t know if the vibration is still there?

I replaced the double side tape to the one that comes with the Pixhawk (3m thick hard foam )

I really had a hard time to calibrate the compass ;(

I tried over 25 times outside home, same locations I used to calibrate my old pixhawk

but this one refuse to give me a good result!
best I could get using the QGC is on the beginning of the green bar!
and I didn’t like it because the X: 420 something like over 400 as I remember !

and I re-calibrated the compass thinking things will get better, but now the best is on the yellow bar and most of the time on red!

its just frustrating! I know there is interfere but with what?
everything is aluminum even the compass cable I warped with aluminum tape! and away from anything!
just the metal screws that hold the mast and the little screw holding the round aluminum plate that the GPS set on it!

maybe the screws! but what I will have to use if I need to remove them! and why the old pixhawk GPS was super easy to calibrate and I had low offsets numbers!

please correct me if I am wrong…

thank you for all the time you spending with me to make it happen!

Ozzy

sep-14-2019.param (14.1 KB)

(Bill Geyer) #101

Did you try doing the compass cal using the relaxed fitness setting instead of the default. I find that I have to do this more often than not to get a good compass cal.

(Ozzy ) #102

Where to find that setting ?

I am still having problem with calibration

Thank you

(Bill Geyer) #103

Read this wiki on Compass Calibration. Read the section on onboard calibration where it talks about if the calibration fails.

(Ozzy ) #104

Thank you Bill for the link!
I switched to Relaxed setting, but I was not able to get a good calibration, so I switched back to default and calibrated inside the home and got lower offsets numbers… don’t know if I need to get it more lower!

I think I can try to calibrate it at the flying site! maybe I can get lower than 100

but I tested the loiter mode; so when I had a higher Compass numbers the heli was doing toilet bowel in a big area! not good at all.

but when I re-calibrated the compass and got the new lower offsets numbers, I flew it and was much much better and nice steady ! it was not staying holding its position like Drone, it was moving slow within few inches

maybe within 1 Sqf … and mostly on the pitch axis (tipping down and up) like bird eating :blush:

I also replaced the new shaft with another brand new one, also replaced all bearing blocks’ bearings and lubricate all bearings, re tracked the blades and greased the red gears to give smoother run!

what do you think if we tryi out the ALT hold or other modes maybe Auto?

thank you
Ozzy