Servers by jDrones

Trex 450 Tunning


(David Ardis) #1

I finally got the flybarless Trex outside today could someone take a look at this log especially the PID section not sure if this looks wright

Thanks
David Ardis


(Chris Olson) #2

David,
Your pitch rate P gain appears to be zero for some reason
ATC_RAT_PIT_P,0

You may have entered the value and then forgotten to write it to the flight controller.


(David Ardis) #3

Chris

Could you have a look at Roll Axis and see what you think as i don't really know that to look for in the PIPR Log entry.

I have noticed in mission planner that sometimes if you are tuning the values for both pitch and roll both don,t save but I cant reproduce the problem every time to report it.

David Ardis


(Chris Olson) #4

David, I see it using the full range of the PID settings, but must've been flying fairly gently as it didn't use all of the Fastforward. Actually looks good to me.


(David Ardis) #5

Got another 2 short test in today but looks like i have a problem with PIDA as it appears to be IMAX limit I think. What do i need to adjust.
Enclosed are links to 2 log files

The problem was a lot worse in the first flight as there is a bit more wind.


(Chris Olson) #6

Hi David,
For right now, it appears these are low speed or hovering tests. At least you are not in dynamic flight (>5m/s for 2 seconds). So you are carrying zero I gain due to the leaky integrator. The PIDA messages, I think, are for the collective response (still called "throttle" in heli, which is a carryover from multirotors).

450's are extremely responsive little helicopters, and more easily upset by wind than a larger, heavier one, so are more of a challenge to tune.

A couple things I would look at - I notice you are running ver 3.5.1 of the firmware. We have gotten a lot of fixes for TradHeli into 3.5.4 now, and I would strongly suggest upgrading to that version.

The second thing is that the ILMI parameters for rate pitch and roll set the minimum I-gain that the system will carry in hover and when the heli is not in dynamic flight. Setting those can improve the attitude accuracy and rejection to wind and disturbances in hover. So the problem used to be that letting the integrator build on the ground could cause a tipover. So @bnsgeyer wrote code to fix this and reset the I-terms to help prevent it, and this is now in Copter 3.5.4

So I would consider setting your ILMI values for rate pitch and roll to maybe .04 to start with, to carry a little I-gain in hover, and thereby provide a little "autotrim" to improve attitude accuracy. In the future, considering the commit above, I think we should look at setting these to maybe .02 by default for heli's so people aren't flying with no I-gain "out of the box".


(David Ardis) #7

Chris I have made the changes you suggested but still no better enclosed is the log file from a very brief and interesting flight.

Thanks David Ardis


(Chris Olson) #8

It basically looks like the helicopter is not stable and over-reacting to control inputs. The RATE messages show a lot of overshoot of the rate in this log, which indicates the VFF is too high for this helicopter.

Getting the rate right is the hardest part of tuning. What I would do is record your rate PID settings, then zero them out for pitch and roll, including the ILMI's. Leave the VFF where it is right now at .11 and hover the heli just using the VFF. Make some sharp stick inputs in both pitch and roll, pull the log and look at the RATE messages. This is the graphs we'll be looking at:

In that graph notice how the actual rate is exceeding the desired rate by a considerable amount, in this case in the roll axis. When you make the sharp stick inputs hovering in Stabilize it will cause peaks in that graph for the desired rate. What you want is for the actual rate to have the same height (amplitude) peaks when you make those sharp stick inputs to pitch and roll the heli. When the actual rate is too high, it causes the heli to respond extremely fast. Which can make it unstable. The lines in the graph will not be exactly on top of one another. What you're looking at is the amplitude of those rate peaks when you make a high-rate request with the sharp stick inputs.

Once you get the rate so it's responding properly, then re-tune the rate PIDS's and reset your ILMI back to the values you recorded, and try it again to see if it's smoother.

Being this is a 450-class and they are notorious for being extremely fast-handling heli's, the VFF values will likely need to be lowered some to get the rate to match desired. But don't short-change it by being gentle with it, or you'll over-tune the VFF. Slam it full-stick back and forth to make the maximum rate request so you can get it tuned properly.


(David Ardis) #9

Chris

Got a few test flight done this evening with different VFF settings (2 Logs are included below).
2017-12-06 21-02-12 (08).bin had the VFF set to 0.08 and 2017-12-06 20-29-10 (09).bin had the VFF set to 0.08 my feeling is 0.09 is probably the right value as it appeared more responsive. Can you let me know your feedings on the logs and was i giving it enough movement.

David Ardis


(Chris Olson) #10

Hi David,
I’m liking the look of the rate much better with it at .09. Notice how the amplitude of the peaks pretty much matches up.

Before you tune PID’s, though, one thing I noticed is that if this is a FBL heli, now, please set H_FLYBAR_MODE = 0. You have it set to 1 yet for a flybar heli.


(David Ardis) #11

Chris

Thanks for looking at this as I reduced the value I didnt notice much difference until 0,09 which was much more responsive and I felt 0.08 was too far. having little experience i didn’t know what to expect.

Light bulb moment forgot to change H_FLYBAR_MODE=0 that probably why it was hard to tune.

David Ardis


(David Ardis) #12

Chris

Finally got the 450 outside today for a test flight and it was much better. Forward flight was good but though i noticed a bit of a rock in pitch hard to say. In the hover the twitching appears occasionally but not too bad

I don’t how to read the logs but something does not look right for the Pitch and Roll I gains.

Thanks

David Ardis


(Chris Olson) #13

I’m not getting notifications sometimes. Anyway, I looked at your log. The response and rate of the heli’s controls looks about as good as you get. However, you are getting a slight pitch oscillation. Look at this graph:

Notice how the nose goes up or down, the elevator (pitch) servo goes the other way and tries compensate for it. The autopilot’s stabilization system is not driving it, it’s trying to damp it and compensate for it to stabilize the heli. Which indicates a mechanical issue causing the pitch oscillation.

It could be tail or nose heavy and getting the classic “tail bounce”. On Trex helicopters sometimes speeding the head up takes care of it. But if I remember right you’re already turning 3,000 rpm or so. The other thing is blade tracking. That can cause it by one blade running more pitch than the other. Or sometimes changing the CG by moving the battery ahead or back to get away from the point where the frame likes to jump in pitch works.

It’s definitely there, and from what I see not a problem in the tuning. The tuning is doing a very good job of keeping it under control. I wish I could say what mechanical issue is causing it, but those are some of the things I’ve found that can cause it.

If it was me, one thing that’s pretty easy to change just to experiment to see if the tail bounce stops is headspeed. If you’re already turning pretty high, try it slower once and see what happens. If it gets worse or better, or goes away completely, you know you’re on the right track looking for a balance issue.


(Chris Olson) #14

@ardisd if you put the helicopter on a flat table, place a ruler by one of the blade tips, carefully rotate the head until the other blade comes around, how close are they are in static track?

It seems to me that you took a flybar head off and put a FBL on. The dampers that come in most FBL heads are really, really stiff for quick response for 3D. If you can’t find any balance or tracking issues, I have pulled FBL heads apart and put the grey dampers in from a flybar head, which are usually softer than the black or green ones. It makes the head a little more like a “teetering” head instead of a semi-articulated head, and can make a difference for UAV.


(David Ardis) #15

Chris

You are correct just swapped the flybar for the FBL head. I did look at the dampers when I was building it and thought they where a bit hard basically just a bit of hard plastic.

Will check the tracking and CG over the next few days and report back.

Thanks

David Ardis


(Chris Olson) #16

Yeah, I basically don’t like those dampers. They are too hard for my tastes. The softer dampers soften the response of the head a little bit and it helps. It softens the pitch response of the blades by allowing, in forward flight for instance, the advancing blade to “flap” down and the retreating blade to “flap” up, more like normal helicopters work. By putting in those rigid dampers they can make the pitch be super responsive for 3D pilots. But what they like and what we like is usually two different things.