Trex 450 Pro APM ESC Calibration problem

I am setting up a Trex 450 flybarless with APM2.5. I have removed the 3GX, and have completed the radio calibration step in Mission Planner. All the servos move in the correct directions. But I can’t enter the ESC calibration mode with the main rotor ESC connected to APM output #8. I tried both the Align ESC (RCE-BL35X and Turnigy Trust 55A SBEC) with same result.
If I connect the main rotor ESC to the Rx throttle channel, i.e bypass the APM, I can hear the normal ESC musical tone and the No. of beeps corresponding to the No. of cell. and get the motor spin. This is because I completed the ESC calibration procedure beforehand.
I am flying a plane (Penguin) and a quad, both are APM controlled with no problem calibrating the ESCs.

Is there any step missing in the instruction about calibrating ESC in traditional heli ?
Appreciate any help.

DSM2 Rx (9 ch)
Arducopter V3.1.5 (heli)

This is a weakness in the helicopter program, there is not easy or good way to calibrate the ESC. Typically I plug the ESC directly into the Rx Ch8 to do the calibration.

Either that or… I think you can take all the blades off and/or mechanically safe the copter, unplug the ESC, Boot up the APM, Set RSC Setpoint to 1000, arm the copter, and set Ch8 high to switch on the motor and wait for the ramp time. The APM should now be outputting full-speed. Now, plug the ESC in, and it should see the high-PWM, and beep waiting for the low-PWM. Now switch off Ch8, and the APM will output low PWM. Calibration should now be complete. Set your RSC Setpoint to whatever you’d like.

Thanks for your reply. I did try plug ESC to Rx, both throttle channel and channel 8. It did not work.

For channel 8, since my Tx is 7 channel Spektrum DX7S, I think it would not work.

Your suggestion to calibrate ESC thru APM is also listed in Mode 2 (H_RSC_Mode Set to 2) in Wiki under Trad Heli Config. But you can also disable Ch 8 according to Wiki which I did by setting H_RSC mode to 0. Again it did not work.

Since my Tx is 7 channel, do I definitely have to disable Ch 8 as I don’t have enough channel ? Pls help.


It sounds to me like a PWM issue. I bet if you lower your trim to the bottom or lower the PWM output to the ESC then it will arm.

It sounds to me like the real problem is that he doesn’t have an 8 channel radio? How do you plan to control the ESC?

Can I plug the ESC to APM output #6 or #7 (instead of #8) and assign a switch to the corresponding channel in my Tx , so as to control the ESC ?

If yes, do I have to run a male to male cable from the APM Output (Say CH #7 ) to APM input (CH #7) ?

You need to plug your ESC into #8 output on the APM. I used a 7 channel system, BRIEFLY, a little over a year ago. You’re gonna need to use the channel 6 or 7 output of your receiver as the input into 8 on the APM. I don’t know anything about the DX7 transmitter but a switch or a knob should be able to give you a high and low signal out of your receiver on those outputs. Keep in mind that you will lose the intended function of the receiver output ( tuning or save trim, flight modes etc.). Be careful and understand what you are trying to accomplish.
David R. Boulanger.

Hi David,

Thanks for yr reply. I did what you suggested , but didn’t work. Here was the set up :-

The 1st 5 Rx channels were connected to the respective channels of the APM inputs. Channel 5 is for 6 flight mode. This requires mixing of channel 5 and 6 in my DX7S Spektrum Tx. That leaves CH 7.

I ran a wire from Rx channel 7 to APM input #8. The ESC was connected to the APM output #8.

With my Tx Ch 7 ( a knob) activated and the Rotor Speed Control set to " Ch 8 Input" in Mission Planner Trad Heli Config page, I set the TRAVEL of the CH 7 knob of my Tx to 0% for low PWM signal and 100% for high PWM signal.
Then I switched on the Tx and placed the throttle to max, powered up the APM, armed the APM by pushing the rudder stick to far right, unplugged and then plugged the power to APM, no matter at what position of the knob (high or low), I still could not get the familiar tone for calibrating the ESC,

Could you advise what step did I miss or what did I do that was wrong, or different from what you did that failed to enter the calibration mode with APM connected to Rx. ?

FYI : The ESC is Align RCE-BL35X that is included in the Align Trex 450 Pro.

Appreciate your help.

Frankie, Try calibrating the ESC directly off of the receiver on channel 7 and not through the APM. Also if channel 5 will give you 2 flight modes without mixing it with channel 6 that would be a good place start. You’re gonna need channel 6 available for tuning. You only need STAB and ALT HOLD to begin with in my opinion. Last but not least you may want to invest in a 8 channel transmitter. Also Rob explained earlier in this post how to calibrate through the APM, but I just think it is easier to do it right off the receiver.
David R. Boulanger

Hi Dave,
I tried CH 7 and used it to calibrate the ESC. But still did not work.

I am wondering can the ESC recognize the signal coming from APM after it is connected to APM output #8 (since it was calibrated off the Rx) ?
DO you think the nature of signal will change when going from APM input #8 to output #8 ?

If you can remember, was it a straight forward procedure of ESC calibration (also directly from Rx ? ) when you did it on your heli a year ago ? Nothing tricky ?

I have exhausted all the possible ways to calibrate the ESC and still don’t know what has gone wrong.

Thanks for your continued help.

You must be doing something wrong. Try reading the traditional helicopter section of the wiki again.

David R. Boulanger

I finally solved the problem by doing what swhitney advised :-
Set the PWM output to minimum to ESC through APM #8 , then the APM can be armed.

But, when I followed the Wiki to disable CH 8 by setting H_RSC_MODE to 0,
I can arm the APM by pushing rudder stick to full right (collective works), and the pink LED on APM becomes solid, but the motor does not spin.
Is it necessary to change the wiring when disabling CH 8 ?

Hi David,

Thanks for your help again. I have read the Trad Heli section of Wiki many times. The section on disabling Ch 8 (set H_RSC mode to 0 ) is quite short and simple.
Starting from everything OK when setting H_RSC mode to 1 or 2, I can arm the APM and spin the motor.
But when I change the mode to 0 , the only thing I change, I can’t spin the motor even though I can arm the APM.

I don’t understand why the motor can spin if CH 8 is disabled, unless the wiring is changed.


Did you get this solved yet (reading the other thread, it seems you did?)

Hi Rob,

I did have the ESC calibration solved.

Now I use your suggestion of using a knob to control Ch 8 in-flight rpm, But how do you at the same time use a toggle switch to control the same channel (CH 8) as throttle hold , as you can’t have both the knob and the toggle switch assigned to the same channel (CH 8) ?

One more question :-- Just for curiosity, if I want to disable CH 8 by setting mode to 0, do you plug the ESC to channel 3 (throttle) of APM ? If yes, then how do you control the rotor speed , as you don’t separate the collective with the throttle ?

Thanks for your help.

Combining the Ch8 knob and a switch must be done in your radio with mixing functions. This is an advanced topic, and depends on your particular radio, so I can’t help you with that unfortunately.

If you don’t use an RSC Mode, and wish to control the ESC directly, you do not plug the ESC into Ch3. You need to use a spare channel on the Rx to drive the ESC.