TradHeli - RC Failsafe

Hello, does anybody use RC Failsafe for low PWM feature for TradHeli? Is it even possible to set up for TradHeli / if yes - how?
It’s about parameters FS_THR_ENABLE FS_THR_VALUE

so - nobody uses such a failsafe configuration for heli?

Yes, I do.

David R. Boulanger

Thank you for your reaction - can you please explain me which channel is configured to trigger FS - is it collective pitch (ch 3) or rotor throttle (ch 8)?
if it’s channel 3 - what happens with collective value if RC FS is triggered? does it move swash-pate down or is the behavior different?
Probably I’m missing something because I was not able to configure low PWM RC FS for TradHeli, for my plane it just works fine.

The code is expecting a low PWM on channel 3 to trigger the failsafe. It needs to be set properly on your receiver and on mission planner. The swash will not drop down. It will disarm if you have not taken off yet or RTL or LAND ( IIRC ) depending on what your failsafe action is. I think all this is in the Wiki and this comment is based on just on my memory. In other words, Don’t take my word for it, look it up and double check.

David R. Boulanger

Finally I was able to configure RC FailSafe. The issue before was that low PWM RC FS is not triggered for disarmed model - you have to arm it before testing (tested on AC 3.2).
I’m using er9x on Turnigy 9x with FrSky FrSky V8FR-II receiver. This is what I did:

  1. I’ve stored my current min ch3 value as FS position for RC receiver - it was about 990 ms according to MP’s status monitor.
  2. Then I’ve limited ch3 PWM output by different curve in er9x (-96% - 96%).
  3. Manually I’ve changed following APM parameters for CH3 to skip Radio recalibration (according to min and max ch3 in values in status monitor in mission planner):RC3_MAX,1985 RC3_MIN,1018 RC3_TRIM,1018
  4. I’ve set parameters for low PWM RC FS like: FS_THR_ENABLE,1 FS_THR_VALUE,1007

That’s it, thanks to David for his advice.

Failsafe trigger, or is determined by the value of ch3, but Failsafe value Radio TX end ch8 channel needs to be set when the normal flight control pwm value ESC, otherwise, triggering failsafe after, ch8 after losing TX signal , will return to the lowest pwm, in that case, the copter crashed directly freefall!


Yes, this is a good point.

If you are using programmable failsafe channel values in the Rx, (ie: use Ch3 Low to signal failsafe), you need to be sure to program Ch8 to keep the motor running.

I now use “No Pulses” option on my Rx for failsafe. When you do this, all channel values in the Pixhawk remain at their last value, so the motor remains running, in my experience.

1 Like