Servers by jDrones

Tracker Compass calibration not working

I am trying to calibrate my compass, but the live calibration is not available some how, and the onboard calibration cant get past about 20%… when I apply the values at about 20% it also doesnt work, all offsets remain 0.
How can I solve this? Is my compass just bad? (it seems to work fine).
Can I somehow try to use the live calibration?
and could I try to mount the compass to another controller, calibrate it there and copy the offsets?

thanks,
Jonas

The old live calibration is less accurate than the new on-board calibration. You can reduce the tolerance if it wont complete on the default. Not completing is most likely due to mounting. It should be mounted on the ‘head’ of the tracker with the flight controller and well away from anything magnetic.

I know live calibration is not as good, but at least it worked, so is there any way to still use it?
it is mounted very good, tested outside , and inside.
tolerance is already in relaxed

If the relaxed calibration is not working it it because the compass is giving bad data rather than the calibration being broken. As I said in most cases this is due to the mounting location, try moving it further away from anything metallic. Maybe you could post a picture of how it is mounted.

I dont think the compass gives that bad data, as Live calibration has worked with the older FW versions, and when I point it to north its not bad and only few degrees off.

I dont know how I could mount it better, I think its good?
heres a picture: https://photos.app.goo.gl/aSTvzu1iJyWGPAav5

Your quite close to the big servo, probably worth moving it abit further away, maybe double the distance.

I calibrate with all the electronics unplugged, just USB…

its still a big lump of metal

Servers by jDrones