Servers by jDrones

Tiltrotor support for plane


(Andras Schaffer) #443

Guys ! Thanks all of you who posted info in this topic. Based on the info from here and some digging in the code, I successfully maidened my vectored yaw NIMBUS 1800.


(tridge) #444

fantastic, congratulations!


(lucamax) #445

Great !
What motor / propeller setup are you using ?


(Greg Covey) #446

Hi Tridge,

I am ready to change my FireFLY6 DIY15 model to APM so I am gathering information on what steps are needed and some details. Let me know if you think this is correct or have additional documentation elsewhere.

It does not appear that the AvA version of the FireFLY6 used a standard copter frame layout. My assumption here is that you are using the New Y6 layout below.

  1. Remove props and load Plane v3.8.2 on Pixhawk
  2. Load your .param file and update PIDs from post above
  3. Change motor directions to match New Y6B layout
  4. Use which Main/Aux Out ports for Motors 1-6?
  5. Elevon and gear ports?

Cheers!


(tridge) #447

I added the Y6F (for “FireFly”) layout to ArduPilot a while ago. It is in 3.8.x.
The layout is:

  • Motor1: rear-CCW
  • Motor2: front-rght-CCW
  • Motor3: front-left-CCW
  • Motor4: rear-CW
  • Motor5: front-right-CW
  • Motor6: front-left-CW

I believe this is the same layout as the AvA firmware (but as I’ve never flown AvA, please check).

I used:

  • main1: left elevon
  • main2: right elevon
  • main3: Motor1
  • main4: Motor2 (and so on for 6 motors)
  • Aux2: gear
  • Aux3: tilt servo
    but you can use any layout you want.

(Greg Covey) #448

Oh my…you rock! :slight_smile:


(Greg Covey) #449

I started a new thread in Plane v3.8 for the FF6 here. It will help to consolidate changes on the first post.

Thanks again, Tridge!


(Greg Covey) #450

Tridge,

When programming your new values in over the .param file settings, several of them were out of range. I programmed them anyway but wanted to make sure this was ok.

Thanks…


(Greg Covey) #451

Tridge,

I have had some success but there are still many issues to overcome. I loaded Plane v3.8.2 via Mission Planner and then loaded your .param file with PID changes. It seemed that there were several errors when loading the .param file (the second time) so perhaps Mission Planner v1.3.49 has not yet caught up to the firmware.

Could you please also download your Taranis .eepe file for the FF6 setup?

Below is one of my main issues. Even after multiple ACC calibrations and Compass calibrations, my horizon is still inverted. I call it the “Down Under” effect. :slight_smile:

Another issue is that the motor output PWM signal does not seem to be available, even after pressing the safety button. The landing gear, flight modes and elevator all seem to work.


(tridge) #452

that just means your IMU orientation is different from mine. You need to set AHRS_ORIENTATION to suit your install. I have a PH2.1 mounted sideways, so I wasn’t using the default orientation.
Cheers, Tridge


(Greg Covey) #453

Hmmm…I did see that and changed mine to 0 on my Pixhawk without having any effect, even after a re-boot.


(Greg Covey) #454

Here is my current .param file with AHRS_ORIENTATION set to 0. When I move the FF6, the x and y axis are reversed such that up and down tilts the HUD left or right.

Why does Mission Planer save a Full Parameter List as a .parm file when this forum does accept that suffix? :confounded:
GregsAPM_FF6b.param (15.8 KB)


(Greg Covey) #455

After resetting the params to default and going through them one at a time, I found another critical one called BRD_TYPE. The default params sets it to Pixhawk, not Pixhawk2.


(Greg Covey) #456

I made some good progress with my new setup for Pixhawk. My HUD is good and I can properly control the landing gear and elevons. The up, down, left, and right are all correct for a wing. Even the normal FF6 up elevon offset is correct. In fact, I can even ARM the plane in QSTABILIZE mode using the rudder and a full arming check.

What’s not working is the tilt rotor servo and ESC PWM outputs. The tilt rotor sits at a 45 degree angle to hover position. All 6 motors continually beep in rapid succession, even when armed. Perhaps there is another remnant of Pixhawk2 somewhere so I attached my latest .param file.

GregsFF6wAPMa.param (16.0 KB)


(David) #457

Greg,

Thanks for sharing your progress. I am following this thread closely as I prepare to transition to arduplane.

Thanks,

Dave


(Greg Covey) #458

Hi David,

I’ll update my thread on the Plane v3.8 forum once I get it working. The main issue was that Tridge’s .param file was for Pixhawk2 not Pixhawk. Tridge suggested that the motor beep issue is the ESCs not arming because the PWM doesn’t go low enough. The settings are 1100 so I’ll try 1000 tonight.

The only issue left will be the tilt rotor servo control. My expectation was that in QSTABILIZE mode, the props should be pointing up and in FBWA mode, the props should be pointing forward but I have no movement.

It’s close!


(Greg Covey) #459

I got the tilt servo to work once I discovered that Tridge put it on AUX3 instead of the stock FireFLY6 AUX1 position. A simple connector change fixed that and I can then change the Servo 11 Max/Min settings to align with hover and forward flight modes per the FF6 manual.

I also changed my servo min settings from 1100 to 1000 (and a few of them to 950) but the ESCs still beep continuously. I mapped all the outputs to the appropriate servo number and function and they all seemed to be correct. I’m not sure why the ESCs are not arming at this point.

Left Elevon = Servo 1 = 77 = MainOutput1
Rightt Elevon = Servo 2 = 78 = MainOutput2
Motor 1 = Servo 3 = 33 = MainOutput3
Motor 2 = Servo 4 = 34 = MainOutput4
Motor 3 = Servo 5 = 35 = MainOutput5
Motor 4 = Servo 6 = 36 = MainOutput6
Motor 5 = Servo 7 = 37 = MainOutput7
Motor 6 = Servo 8 = 38 = MainOutput8
Retracts = Servo 10 = 57 = AUX2
Tilt Servo = Servo 11 = 41 = AUX3


(tridge) #460

as I mentioned in the other thead, the key parameter is Q_M_PWM_MIN. I suspect that is too high.
Note that if Q_M_PWM_MIN is zero then it will use Q_THR_MIN_PWM instead.


(Isaac ) #461

Hello everyone,

I’m new to tiltrotors and I’m planning to build one with four motors. Today I started by uploading the 3.8.2 firmware and setting up the parameters and connecting some servos to test the tilting outputs. These are the parameters parameters that I have changed:
-Q_TILT_MASK 15
-Q_TILT_MAX 35
The rest of the tilt parameters are the default. I have noticed that when changing from QStabilize to FBWA, the servos move from vertical to horizontal position without stopping at all. They run from maximum to minimum position. Is this normal?
The ARSPD_FBW_MIN parameter is set to 16, and the airspeed sensor is used (it is not connected, but theres a constant reading of 9 m/s).

Also I have a couple of question more. Is it possible to use vectored yaw with a four motor tilt rotor configuration?
Is there any possibility to shut down the rear motors once the transition is completed?

Thank you.


(tridge) #462

that is the behaviour when disarmed. It is meant to help testing on the ground.

you should make sure it is disabled if it is not connected.

I’ll need to think about that. Do you have 4 tilt servos or two servos?

at the moment it isn’t, but another user asked for that capability too. I think we need a parameter to say which of the motors should be used for forward thrust.
Cheers, Tridge