Servers by jDrones

Tiltrotor Motors not Responding in Q_STABILIZE Mode


(yx) #1

Hi all, I’m building a tilt tricopter using QuadPlane setup. I’m not sure why the motors don’t work when in Q_Stabilize mode (when the motors are facing up). There’s no response when I move the throttle stick. They work fine when the motors are tilted for forward flight. I followed this link for the tilt rotor setup (http://ardupilot.org/plane/docs/guide-tilt-rotor.html). Is there any other parameter or setup? I am doing a school project and this is my first time using a Pixhawk. Would really appreciate any help, thanks!


(Rolf) #2

I’m not sure, either. The reading of coffee grounds is a genuine practice, but a logfile would be more helpful :smiley:


(yx) #3

Hey Rolf, I tried downloading the dataflash logs using mission planner but the following error appears Error:System.TimeoutException: Timeout on read - GetLogEntry
at MissionPlanner.MAVLinkInterface.GetLogEntry(UInt16 startno, UInt16 endno) in C:\Users\michael\Source\Repos\MissionPlanner\Mavlink\MAVLinkInterface.cs:line 4565
at MissionPlanner.MAVLinkInterface.GetLogList() in C:\Users\michael\Source\Repos\MissionPlanner\Mavlink\MAVLinkInterface.cs:line 4505
at MissionPlanner.Log.LogDownloadMavLink.b__12_0() in C:\Users\michael\Source\Repos\MissionPlanner\Log\LogDownloadMavLink.cs:line 90
I reformatted the sd card but the same error occurs. I’ll upload the logfile when I’m able to download it.


(yx) #4

Hi Rolf, I’ve uploaded the .bin file. Seems like the dataflash logs can only be downloaded when the pixhawk is unarmed. I first set it to MANUAL mode and increased the throttle and then decreased the throttle. I repeated the same steps after setting flight mode to Q_STABILIZE. In manual mode, the servo output in mission planner will respond to the throttle but there is no response in q_stabilize mode. From the logfile throttle graph, it seems like the pixhawk is not responding to the transmitter once the mode is changed.


(yx) #5

I tried to upload the .bin file but it doesn’t seem to work


(Rolf) #6

Hi “yx”,

best way to get the logfiles is by manually putting the sd-card to your windows/missionplanner computer.

Uploading too big .bin files here is impossible, in this case use any cloudserver and “upload” only the cloudadress.

Rolf


(yx) #8

I managed to download to log files through mission planner after pressing the safety switch to disarm the plane. Here is the link to the .bin file https://drive.google.com/open?id=1VGm-nuvIBCKGY6lNhxPqPYzujdh4QEHI
After downloading the firmware again, I still have the same problem. I tried setting up a quadplane instead of tiltrotor but the quad motors do not respond in Q_Stabilize mode either. Could I be missing some parameter that has to be set up to enable Q modes?


(Rolf) #9

For safety reasons props are removed ?

In Q…Modes you have to arm first by ailorenstick:
http://ardupilot.org/plane/docs/arming-your-plane.html?highlight=arm

Your arming settings are very unsafe ! !!!
better is ARMING_CHECK 1, ARMING_REQUIRE 1.

Rolf


(yx) #10

Everything works fine after changing ARMING_REQUIRE to 1. Thanks for your help!