Throttle response Issue

I seem to have an issue with my QCopter

I recently rebuilt the entire system - was working but thought it will be nice to do for a clean-up. In the process I upgraded to the latest firmware

I run a Cube Purple in a mini board. The Here3 GPS is installed on a stand far away from anything else and is connected to CAN2. On powerup here is a 5 second delay in booting the Cube to allow the GPS to boot first.

During the setup I recalibrated the ESC and tested the motors individually. This seems to be ok.
In the “Compass/Motor Calibration” (checked as part of a test) the motors seem to respond in conjunction with the throttle movement of the RC remote. i.e. small stick movement = small speed difference, 50% stick sounds like half speed and full stick sounds like full speed.

Tested arming and disarming (without throttle input) that seem to work as expected.

The issue comes in that if ARMED the motors do not respond to the first 30% of throttle stick movement, then runs (instantly) at a high speed (probably 50% power) and do not slow down when the throttle is moved to zero. Also, the motors do not disarm if a disarm instruction is sent. After a while the FC reports an accident and disarms the motors. This is while the drone is on my desk without props.

The .bin file is at

Any help or advice would be appreciated

Use Mission Planners Motor Test function if it’s on the bench w/o props. If the motors spin relative to the input throttle percent put props on and fly it.


I did that after calibrating the ESC. Tested the motors in the “Motor Test” page and they appeared to be fine. Also tested this in the “Compass/Motor Cal” page and again they appeared fine - reacted relatively to stick movement.

Did not test this as if doing a normal flight without props. Just fitted props and treid to fly (as you suggested, but before I posted the initial question on the thread). Drone motors did not react to the first bit of stick movement, and then spun up quite fast and crashed. Three props and GPS broke off.


Post the .bin log file

The .bin file is at

Any further thoughts on this issue??

All motors are commanded to maximum, and you are using POSHOLD.
Only test in Stabilise then AltHold, after tests and stable flight use Loiter.

Are you even getting airborne in the log?

If you have BLHELI ESCs then turn off LOW RPM POWER PROTECT
What ESCs are they?

Set INS_LOG_BAT_MASK,1 for gathering some harmonic notch filter data

Xfacta, thanks. Yes, that will explain the behaviour.

I’ll make sure I’m in STABALISE and retest a bit later. I’ll set INS_LOG_BAT_MASK to1 while testing and upload the new log file.



OK. Reran the test - same results.

I did a motor test and the individual motors ran as expected.
Then tested under the compas/motor calibration and the moters reacted as expected.

I made sure “Stabilise” was set as the flight mode. Moved the throttle a bit (about 5% movement) and the motors sped up instantly to probably 50%. Moving the stick back, the motors lag quite a bit then return to idle.

The latest log file at

I really thought the “position hold” was the issue as you sugested.



Did you do the test with propelers on?

No, tested with props off.

I’ve had one flyaway in the past (about a year ago). Last week, running the final test before flying, I broke three props and GPS mount. Also, cut my arm to shreds trying to prevent a flyaway - in hindsight, not a great plan.

So, am very wary to test with the props on.


Search this forum for threads with “propellers off” to find under which circumstances your tests are invalid.