Servers by jDrones

Throttle failsafe error

(Rahul Sharma) #1

I am using BBBlue with Ardurover3.2.
All things were working fine but all of sudden one day when i switched on BBBlue, there was no radio signals on Radio Calibration option.
I have tested the rc receiver, its also showing the signals in Oscilloscope. Also BBBlue is working fine with other projects. But still it goes on hold and shows throttle failsafe error and no Radio Signal.
Any suggestions?

(gmorph) #2

Other posts you’ve done Rahul indicate you may have solved this issue. Have you? If so could you please post your solution here?

Thanks, Grant.

(Rahul Sharma) #3

The issue is unexpected and yet not solved. All i have done is in AUTO mode.

(gmorph) #4

If you can enable LOG_DISARMED and run through the process and then send one log file of the issue I can have a look.

Thanks, Grant.

(Rahul Sharma) #5

i enabled the LOG_DISARMED but where i can find that generated log file? I am running bin file of ardurover after cross compiling in my machine.

(Rahul Sharma) #6

Hi, please find the attached log files. I found that in /var/APM/logs (343.3 KB)

(gmorph) #7

Looking at the log its not seeing ANY RC_IN at all. Its like the Receiver isn’t connected. I don’t know of any setting that could prevent RC_IN. So either your BBB is having a problem or your receiver is having an issue.

Hmmm, you do have ARMING_CHECK at 0 but ARMING_REQUIRE is 1. That’s an odd combination. You saying don’t check anything but don’t arm unless the checks pass. I still don’t think this will affect your RC_IN but I’d change it and test again just in case.

Thanks, Grant.

(Rahul Sharma) #8

Thanks for the reply. But i think the combination is like ARMING_REQUIRE is like a main gate to arm that relies on GCS arming/rudder arming only. After that nothing to check as per ARMING_CHECK=0. Correct me if i am wrong.
By-the way i did change that also but no result.
The thing is that i can’t blame RC, as i am seeing in oscilloscope, the pulse is varying according to throttle/steering change.
And i have also tested the E4 port with my roboticscape library (after burning fresh image) that shows the Encoder readings with PRU programming (before running ardurover bin). So the port is also not gone.
But whenever i run ardurover on it, no RC signal there and then also can’t read encoder with roboticscape. For roboticscape working i have to burn a new image.
I am just confused about that. It was working previously but now not working in my two Beaglebone blue.

(gmorph) #9

Interesting. Perhaps we have broken something in BBB. I can see your running v3.2.0-dev so I assume that’s master?

Thanks, Grant.

(Rahul Sharma) #10

That’s master. Is there any issue you think?

(gmorph) #11

I don’t think many people will be running master on a BBB so you “might” of found an issue. I still think its unlikely but if I’ll see if we can test master on a BBB.

Thanks, Grant.

(Rahul Sharma) #12

Thanks for your help.
Just let me know whenever you done test that.