The flight of the quad is not beautiful

Hello everybody

I built the F450 Quad today.

Its flight was almost the worst.

It was a flight in AltHold mode, but the altitude changes at will.

In stab, alt, pos mode, yaw moves

In poshold mode, the quad flows freely.

I’ve made a lot of Quad toys so far, but I’m sure this was the worst.

What will have a big impact on your flight?

As an additional question, what do you do with Alt_source?
I’ve tried both baro and gps but I’m not sure what’s better.

Keep Alt_source to baro and perform the tuning instructions we posted a while ago.
Are you talking about this?

Is this also a pid problem?
I pid tuning only when the aircraft showed hunting phenomenon.

If this is also a pid tuning problem, I will try it.

Additionally, you told me to set the alt source to baro.

If i change it to gps, what change or no problem will it cause?

No, I am talking about this:

Every time the copter does not fly beautifully it is a PID problem.

Please set ALT_SOURCE to baro, otherwise it will start jumping up and down.

If you set the Alt_source to gps rather than Baro, you said that the drone shakes up and down.

I think this is due to GPS drift.

Could this be a problem even when using sophisticated equipment like RTK?

Yes because even with RTK the vertical precision is around 3 times worse than the horizontal precision.

Thanks for the good info.
Actually, even if I asked something here, the answer was difficult to understand, but I understood it because you explained it really easily

I checked that log and you have a lot of X and Y axis vibrations like props are out of balance.
There’s no battery voltage and current monitoring. See if you can set that up and the other fail safes.
Barometer seems badly affected by prop wash.
Try reducing ATC_RAT_RLL_P , ATC_RAT_RLL_I , ATC_RAT_PIT_P and ATC_RAT_PIT_I all to 0.12
I would check that MOT_SPIN_MIN really needs to be as low as you’ve got it set - this is a “fall like a brick with no chance of recovery” setting.

After you’ve got all that done try another test flight and post the new log.

Thank you for answer.
First of all, the low Spin_min value is because the motor turns too fast when arming is attempted.
In Default it turns very aggressive. I think it will take off even if I slightly raise the throttle.

Secondly, no vibration is detected with the naked eye.
Because it is invisible, I had no idea of ​​the vibration.
Thanks for reminding me.

In the case of PID, my aircraft is an F450 quadcopter with nothing on it.
The battery uses 4 cells, and the weight including the battery is only 1.4kg.
pid is Default.

If the vibration is Hunting I definitely need to modify the pid.

You probably want to set MOT_SPIN_ARM lower