The Bicopter Debacle (as requested)

I am working on a (really freaking cool) little bicopter. When I set the frame type to ‘quad’ and assign modes 33/34 to my motors and then run a spin test, everything is good; however, if I change the frame to `bicopter’ and set my motors/tilt servos to 73/74 and 75/76 respectively, I get no motor spin, and no tilt. I am comparing my params against other working craft and can’t seem to figure out what’s up.
Nonfunctional_1.param (18.3 KB)
Am I crazy, or did I just miss something?

Just dumb checking: you have MOT_PWM_TYPE,5, does it work with 0?

Sadly it still doesn’t

I referenced this post What's the different between MOT_PWM_TYPE and SERVO_BLH_OTYPE? and revised my settings, still not cooperating :-/

Your parameters have 75/75 rather than 75/76


If you are going to use Dshot for the Motors as you had it configured be conscious of the Output Timing Groups depending on what Flight Controller you have. Can’t mix Dshot motors with servo’s in the same group.

Yes, I am aware; however reading the documentation on this board (goku 745) motors 1/2 and 3/4 are in two different groups

Thanks for that, been messing with them quite a bit

I found this resource layout for betaflight on their website, it looks like 1/2 and 3/4 should be in two different groups, but sanity check me.

Hey, what version are you using?

On the bicopter I don’t yet use DShot, as there is no ready firmware version for that chip that comes with bidirectional DShot.

On many other vehicles I use DShot600, including a CoaxCopter. This might be relevant since it has servos too. On that coax, I set MOT_PWM_TYPE to 0, SERVO_BLH_OTYPE to 6 and select the motor mask by SERVO_BLH_MASK and SERVO_BLH_BDMASK.

Well check this out:
motors working.param (18.3 KB)
If I change the frame type and the mode for servo1 and 2, I can now get my motors to spin.

What version of ardupilot are you using?

I just noticed that on top of that, the ESC doesn’t fully init when I switch it to the bicopter frame type. even if I disable the tilt-motors… I am officially out of ideas…

startup messages.txt (1.4 KB)

My version is 4.2.1, same as yours.

What is the FW on the ESCs? That is, does it support plain PWM? Some, e.g. Bluejay, do not.

Do you use the motor test feature, or do you just arm and spin up?

It’s BL_heli_32 I can’t get passthrough to work so I am not sure the exact version.

I have two extra serial ports, I suppose I could remap one, although I am not entirely sure how to do that on Ardupilot. I think it means writing a custom hardware-spec and compiling a custom FW.

Any out-of-the-box BlHeli_32 should understand any of the common protocols available, I guess.

I am also somewhat out of the ideas. I would stick for a moment with using PWM everywhere and play with different servo functions on different outputs (removing propellers first), to exclude any obvious things (e.g. burned ports etc). But that’s easy to say when the other person does the soldering…

lol it’s a pile of wires right now, waiting on a reel to arrive before re-printing the upper chassis. What/where do you think I should experiment with?