TF Mini Plus - Distance jumping

Hi there,

I have successfully set up a TF Mini Plus with the latest stable arducopter version and am getting measurements as expected. I noted however, that the reported distance jumps by as much as a meter in either direction every now and then. This happens even though I have the sensor laying flat on my desk and pointing straight at the ceiling. I am getting these kinds of jumps about 4 times per minute.

I investigated a bit further and hooked it up to an oscilloscope to rule out a driver issue on the copter side. The ardupilot codebase is correct, the sensor output is simply garbage. The packages are not corrupted, the checksum is good as well. It’s simply a wrong measurement.

Has anyone else experienced this? I got this kind of error on a couple of sensors running FW 2.0.3 and some running 1.9.x on an arduino. When I ran an arduino with the sensor connected in UART mode, there were no such problems.

Interesting, is it in UART or I2C mode ?
What driver did you used in ArduPilot and what Flight controler and Release are you running?

oh… How do you supply the TF Mini Plus ?

I’m on a Holybro PX4 and running in I2C mode. I run the TF Mini Plus I2C driver and the latest stable ardupilot release 4.0.3
I power it from the flight controller. But as I mentioned earlier, I don’t have any problems whatsoever in UART modes on various platforms; only in i2c mode.

I will try powering the sensor seperately for completeness’ sake

Is the TF Mini the only device on the I2C bus ?
Have you try to pull-up the clock and data lines with 2.5 kOhm resistors ?

I have tried it as the only device on the bus and when attached to an I2C multiplexer which already has pull-ups on it.

Just tried it with added 2.5K pull-ups on the arduino, no change in behavior.

With jut one sensor , it is hard to pinpoint error, I would suggest you get another one

I mentioned this in the first post. I tried 4 different TF Mini Plus sensors and multiple arduinos/pixhawks. This appears to be a systematic issue, that’s why I wanted to know if I’m the first and/or only one to notice this.