Testing Max Speed (without loosing altitude)

Hi I’m testing my copter to check what maximum speed / tilt angle it is capable of and maintain control / altitude. According to ecalc it should be able to achieve 20m/s at 60 deg.

I will try it altitude hold with max_angle 50 deg and slowly increase it. Is there any parameter which limits speed in altitude hold? Or will it pitch forward until it hits the max_angle?

I tested in Loiter mode but it was limited to 45 deg angle.

The reason I’m not using stabilize mode is I want it to maintain a consistent altitude.

First of all, you should update to ArduCopter 4.3.2

1 Like

Hi I’m on 4.1.5 and haven’t upgraded yet as I’m using a branch 4.3 which is still being tested.

I tested in altitude mode in very low wind and it reached the target 20m/s with good control and without loosing altitude but I have a few questions rising out of it.

Why did it the lean angle go to 47 degrees only and not the max_angle (50 deg 1st run and 55 deg 2nd run)?
Is it because motor 2 maxed out?

That raises another question, why are motors 2 and 3 differ so much?

Note: Autotune doesn’t work prob bc of the flexible frame.
I’ve tried following the Hnotch instructions but couldn’t get further than enabling the logs.
If it’s related to these issues, then I will have to try manually tuning. If Hnotch then I might need some assistance to go through the process.

I’m working on upgrading the frame for the next build but I have 10 units with this frame which flies very well for its purpose.

Log file: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

When a motor maxes out the vehicle stops leaning. If you want it to lean more you’ll need a more powerful propulsion system.

Check if your motors are twisted that causes the motor imbalances that you are getting between motors 2 and 3.

One other issue might be the CG. Ist is at the center of the vehicle?

If you are about to sell 10 of these things, read the wiki and configure the dynamic notch filter. It will fly a LOT better.

Ok, i see whats going on here. Its the combination of torque and thrust under load causing the flexible arms to twist and resulting in motors being out of alignment. Thats why flexible frames are not good. Still reasonable performance - can’t wait to see how it performs with a rigid frame.

CG is near perfect.

I’m slightly lost on the hnotch setup. :slight_smile:
I’m following this page: Managing Gyro Noise with the Dynamic Harmonic Notch Filters — Copter documentation (ardupilot.org)

Is it as simple as:
and INS_HNTCH_MODE = 1 and the notch filtering is automatic?
Or do I need to analyse the logs and enter the frequencies manually?

No, you first need to update to ArduCopter 4.3.2 then:
and reboot the flight controller

And analyze the logs and enter the frequencies manually.

1 Like

After enabling the logs, which parameter do you refer to, to find the frequency?

It’s not a parameter it’s an FFT analysis tool.
In Mission Planner Setup>FFT Setup> Click the FFT button and load the log file.
From there you will either have to read the Wiki for how to interpret it and configure the filter or have someone else do it for you.

But there will be no data there unless you 1st set INS_LOG_BAT_MASK to 1 before making the AltHold hover flight.

1 Like