Terrain Data Load Without GCS

Hello everybody,
I wanted to ask if you could solve a problem I have with autopilot and mavros.

I have a pixfalcon autopilot with arduplane 4.0.5 and the terrains loaded in the SD. When launching mavros, I want to read the height over the terrain that my autopilot has and it gives me a constant height of 0 meters (being the autopilot at 4 meters). As far as I have looked there is a mavlink message called TERRAIN_REPORT: Messages (common) · MAVLink Developer Guide
This message has two parameters: pending and loaded. The first one shows you the terrains pending to read and the second one the maps already loaded in the autopilot.
Reading this message gives me 54 maps pending to read and 0 not loaded. When I leave it for a while it still doesn’t load any map.
To check that it wasn’t a problem with my autopilot, I opened the mission planner and saw that everything was fine. Then I tried again mavros in the autopilot and the height to terrain started to work.

I would like to know if you can tell it through mavros that the terrain is already downloaded and I don’t need a GCS to start loading it.

Thank you in advance for your time.



This is the first I did.
I changed the autopilot version to the latest 4.1.7. The only difference is that the pending parameter is set to 504 but does not change from peding to loaded. I don’t know if I have to send the signal or if it’s a bug in the version itself.

I found the solution. When updating the autopilot version, do not update the version of the maps that are put on the SD. So, update the maps and that’s it.

Thanks to all of you