TeraRanger TowerEVO PreArm: Check Proximity Sensor


I’m trying to set up a TeraRanger TowerEVO for collision avoidance. I followed the instructions on the TeraRanger wiki page and used serial 4 (GPS 2) on the pixhawk 2. I am running ArduCopter V4.0.7.

I have checked and double checked to make sure that my connections are correct and that I have configured the proximity type and baud rates properly using the information given on the wiki page.

I am getting an error message that reads “PreArm: check proximity sensor”. I can’t really find any information about how to fix this problem and I don’t know what my next steps need to be. The tower does not seem to be sending any distance values to the Pixhawk, as the green LED is not lit. The tower works when I connect it to the Terabee GUI via micro USB.

If anyone has any ideas on what I can do to fix this problem I would greatly appreciate it and be open to any suggestions. Thanks so much.

Best, Cole

Hi @Cole_Dickerson, can you share your param file here so that I can have a look at it

Good day, just check also the battery you are using coz some batteries with low mAh don’t provide enough current, check also pls the way you wire the cable… TX-RX and RX-TX

Terabee Tower Evo Hexacopter Param List.param (18.4 KB)

Hey @rishabsingh3003,
I have linked my param file. Thanks so much for taking a look at it.

Hey @Dave84 ,

I’m using a battery external from the copter to power the tower. It is 4 cells, 14.8 V, and 3700 mAh. I believe according to the user manual for the TeraRanger Tower Evo that this should supply enough current. (TeraRanger Tower Evo should max out around 1100 mAh)

I wired the cable TX-RX and RX-TX as specified in the picture I’ve linked. My cable should be correctly wired assuming the pinout in the picture I linked is correct.

Let me know if you have any other suggestions as to what I can do to get this working or if you can tell I’ve done anything wrong. Thanks so much!

Can you check if your Serial port 4 is also the physical Serial port in your Pixhawk ?
in which Mode are you flying ?
Best !

Hey @JLAsensio,

I’m not exactly sure what you mean by the physical serial port. I know that serial port 4 corresponds to the GPS2 port on the Pixhawk 2.1, which is what I’ve plugged my Tower EVO into. I also have not tried to fly the copter yet as I haven’t been able to see that the Pixhawk is receiving any data from the Tower EVO in the proximity radar window on the flight data screen. I’ve tried a few different flight modes including Althold, Poshold, and Stabilize while the copter was grounded. I don’t know what I’m missing or why the tower won’t seem to communicate with the Pixhawk. Thank you for your help and let me know if there’s anything else I can try to get this thing working.

Settings are all correct…seems a wire issue.
Ive done some test with mine and work properly
Pls provide pic the way you connect all

Hey @Dave84

I’ve attached pictures of my connection to the TowerEVO and the wires I soldered together (which I checked with a multimeter to make sure the connections were good). I connected that to the Pixhawk(GPS2 port). Let me know if you see anything wrong. Thank you for your help.

did you check the correct pinout of the GPS 2 port?


Everything I’ve been able to find regarding the pinout for the GPS2 port agrees with the pinout image in my initial reply to you. If that is incorrect please let me know and I can try to change something. Thanks again man.

try reverse cables on the connectors… i mean tx and rx


I got everything figured out and the sensor is working now. Thank you so much for your help. For anyone else who may run into the same problem, I had tried to switch the sensor to a different port (TELEM 1) and the Pixhawk was trying to run the sensor out of two different ports. I had the SERIAL1_PROTOCAL and the SERIAL4_PROTOCAL parameters exactly the same and it would not work. Hope this helps anyone else who may run into the same issue.