Telemetry not working constant green lights - Solved

Hello everyone,
I send you this message because I have some problems with the telemetry I use on my drone (FC : Matek H743-Wing V3). I am using Mission planner and I have configured the SERIAL with the correct parameter (protocol + Baud rate)

Both modules (ground and air) have a constant green LED and are on version 2.2. However, I can’t communicate with the flight controller (I get a timeout after 30 seconds). Has anyone had a similar problem? Thanks a lot!

Make sure you don’t have the RX and TX lines crossed up on the FC.

Radio TX goes to FC RX, and vice versa.

Hi Yuri,
Already done but thanks ! I don’t really know what to do. Both radios are constant green + red lights blinking. I try to chang the baud rate for the USB connection but still not working.

You might switch those two wires around, just to rule out a silly mistake. It’s the most common cause of problems like this.

Otherwise, make sure that SERIALx_PROTOCOL=2, and SERIALx_BAUD is a valid value and matches what you have set in the radio (usually 57 or 115).

Double check the UART number to SERIALx mapping as well:

Default UART order

  • SERIAL0 = console = USB
  • SERIAL1 = Telemetry1 = UART7 (support CTS and RTS signaling)
  • SERIAL2 = Telemetry2 = USART1
  • SERIAL7 = USER = UART6 (TX only unless BRD_ALT_CONFIG = 1, then RX available also)

Hi yury thanks you a lot for your help !
I check everything you say and i don’t think i made a mistake there. I can add that when I connect the ground station to my computer via USB, it crashes mission planner/my computer sometimes.

Hi Yuri,
Thanks you very much ! I’ve found the problem in 2 steps :

  • Reinstall all drivers and set Baud Rate to 9600 on the USB port (and 57600 in MP).
  • Increase the distance betwenn the two modules

Why 9600? That seems to make no sense.

I have no idea but it seems to work. When i put 57600 on the USB port my PC crash and I can’t connect to MP with the device