Servers by jDrones

Telemetry module driver problem


(Newestbie) #1

Hello everyone.
IM new to drones and I built my first quad.
I have APM2.6 with 915mhz radio telemetry . Not sure if its 3dr but windows sees it as Silicon Labs CP210x USB to UART Bridge (com8)
I installed everything correctly on computer , mission planner connects apm over mavlink.
While installing to my laptop , I made mistake, I insert telemetry module before install mission planner. Windows found it CP2102 USB to UART bridge but couldn’t find any driver to install , so it has warning on device manager.
Later I installed mission planer, I tried to uninstall device but whatever I tried driver still missing, I tried to assign driver manually , but couldn’t find it in driver list or in mission planner folder under drivers directory.
Anyone has experience with this telemetry unit?


(meee1) #2

no genuine 3dr hardware has the silicon image chip, so you will need to track down drivers for that.


(outlawzz) #3

Not to difficult to find…

silabs.com/products/mcu/Pag … ivers.aspx


(bobt2000) #4

I hesitate to re-open this topic, but I can’t find the solution anywhere else…yet.
I am using Win 7 Pro…32bit (small Panasonic Toughbook Tablet).
MP runs fine and connects to APM via USB.
I had the same driver issue, downloaded the drivers…no problem.
But now when I try to connect, after about 5 seconds I get the “blue screen of death” and shut down.
I have rolled the drivers back twice and reinstalled, but same problem.

I had no problems on my home laptop…that I recall.


(Andre-K) #5

that’s a part of the Windows experience, not Mission planner issue, you can try to fresh-install windows, and hope it works for a while, even after installing device driver for a device that existed at the time of windows 95.

…or you can just install some Linux distro, no drivers will be necessary, and APM planner 2 will do the job very reliably.


(bobt2000) #6

Bit of an update…
When I plug in the USB telemetry radio into the laptop it is recognized…no errors in Device Manager.
I can select it in MP.
WITHOUT the copter powered up (no battery) the laptop tries to connect but obviously times out as would be expected. I tried this 3 times because i was trying different baud rates. But NO BSOD !
The very next time I powered up the copter and try to connect, I get BSOD in about 5 secs…as soon as Mavlink connects ( I think).
I compare the settings in this laptop to my main laptop (that works flawlessly) and I don’t see any difference. Other than faster processor and more RAM in my main laptop.
I have memory dumps from the BSOD if anyone knows how to read them.


(bobt2000) #7

RE-SOLVED…
I rolled back 1 version of the driver and it works now…That was the only driver difference between the 2 laptops.


(Sergio) #8

Hi Buddy
I have the same issue, I replaced my computer Hard Disk and installed everything again, but now does not work the telemetry connection via mavlink.
Which driver are you using for mavlink connection?
thanks
Sérgio


(OldGazer) #9

I just saw this. The problem could be the Windows 10.1.1 “Universal Driver.” I had to roll back to 6.7.5

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers


(Ivan Ortega) #10

Hello I have the same problem, already had tried using differente drivers from the same web page and stil can’t conect pixhawk with mission planner, bauds on pixhawk are already on 57, net id is the same


what else could be missing? thanks