Tank rover crab walking to waypoints

Im using a pixhawk 2.4.8 with a tracked vehicle. Manual control works fine. But when I set a waypoint mission the rover crab walks to each waypoint. https://youtu.be/Unl9IT03PNY
I have the esc’s on one and three as recomended. and channnel 1 and 3 set to throttle Left and right.
ANyone have any ides on what could cause this? Does anyone have a working track setup file I could use to check my settings? Thanks

Manual mode is simple pass through, the Flight Controller isn’t doing anything. Did you follow the tuning process starting with speed and throttle controller?

And before attempting Auto make sure it’s driving correctly in Acro mode.

No I havent. Im trying to go through that now. The instructions are extremely confusing. What is the
" use the “Learn Cruise Speed” [auxiliary switch]" ?

I had not tried Aero mode. I just did its all over the place. Its not responding to the radio correctly at all. I think its not picking up radio dead space for some dang reason.

You configure a switch on your transmitter for a particular RC channel (7,8,9 whatever) and then set that as the channel option. So if your assigned switch actives channel 7 then set RC7_OPTION to 50 (learn cruise). This must be done before advancing and it’s only the 1st step.

It must drive correctly in Acro mode or it won’t drive correctly in any assisted mode.

I don’t know what this means:
I think its not picking up radio dead space for some dang reason.

I dont know , in acro mode it just started spinning and changing direction rapidly. It changed direction so fast and at full acceleration and trashed my gearbox. Ive got 20 hours of gear printing before I can try again. I think Im going to reset everything to the defaults and start over. Is there any way for me control how fast it accelerates? If its going to just keep tearing up gearboxs than I may as well look for another platform or a different vehicle.

Perhaps so. You can expect to run into things with a Rover unless you are always in an open field or have a RTK GPS system and a well tuned vehicle. It should be robust enough for full throttle acceleration. And while crash detection does work some ground will be churned up before it activates. One of my rovers has a plastic spur gear which is the sacrificial part that fails if over torqued. Cheap and easy to replace

thanks for the help. one the new gears are printed Ill re flash the firmware and start from squire one. you have givien me another step to try with the tuning . maybe that will lead somewhere.

The response you are seeing indicates that your rover is not able to control its heading accurately - which is not surprising if you have not tuned it. The navigation controller tracks a point a certain distance ahead of the rover on the path to the next way point. The controller looks at how far off course the rover is and attempts to turn towards this dynamic target point. Your rover is obviously turning too far in response to the controllers request which in turn, requires it to turn back - which it also does in the same fashion and overshoots. This is the ‘crab walking’ you see. The tuning process linked above is an essential step in getting your rover to navigate well because this is what scales the output to match the expected response. With out effective tuning, the navigation controller can not effectively control the vehicle.

I got it working. It wasnt the tuning although I did fix that. It all broke down to right and left. Im former army, in the army we were taught the right and left of the vehicle was determined facing the front of vehicle. So the right side would be the drivers side. I watched the motor test video but didnt catch on that the front of the rover was pointing away from the camera. Long story short. I hade the left motor plugged into the right motor plug and viscera. Once I fixed that it worked like a charm. LOL two days of frustration for that simple mistake.