Take off slalom Problem

I sent a command to my drone to rise 2 meters in guided mode, but when I saw it doing slalom in the air, I disarmed it as you can see.I think the reason why the drone is not stable in the air is related to the PID parameters. What parameter could cause this problem? I also got a short log of this situation.

Video ► https://drive.google.com/file/d/1uTfh6xcClzGVJe-LoWmJJLUnADnz2JdT/view?usp=sharing
LOG ► https://drive.google.com/file/d/1vp_lv0FQTGVv7pBijPUI2Q-MJBEzHAPy/view?usp=sharing

Did you read the documentation?
Did you configure the Notch filters?
Did you do the mandatory PID settings?
Did you update to ArduCopter 4.2.1?

Yes i have build quad before with documentation.
Yes i configured as you see in log.
Yes i configured PID settings according to the graphics and propeller size specified in the documentation.
Yes i have update firmware 4.2.1 stable as you see in log.

Setting the Aircraft Up for Tuning — Copter documentation ← I have configured PID settings according this documentation. Maybe I must set the default PID settings for good flight ?

That log is not of much value. Why don’t you forget about Guided mode for now while you are still tuning. Just make a simple hover flight in AltHolf.
The Gyro filter is probably too low. Are you using the Mission Planner Initial Parameter Setup screen? And those Notch Filter settings can’t be good. 22Hz is too low for a center frequency.


Do you think that the drone does not same thing (slalom) in AltHold mode? İf it is, I can try cause i am not a good pilot. Yes i used MP initial parameter setup screen and i checked also the PID documentation graph on ardupilot site. So, What is your recommend for Gyro filter ?
Also, I knew that low gyro and accel filter value prevents vibration.
These are FFT graphs ;

Go to the Initial Parameters screen in Mission Planner , put in your prop and battery details and accept all changes it offers.

Actually, I already did that :confused:

Have you got a .bin log of just hovering and maybe some gentle movements under RC control?

1 Like

No ı have not cause i am not a good pilot so I must can fly in guided mode.And I have a little log in guided mode as i can say before. would this log work to comment the flight ? https://drive.google.com/file/d/1vp_lv0FQTGVv7pBijPUI2Q-MJBEzHAPy/view

Loiter and guided mode can cause instability (and are dangerous) IF you have not tuned the copter properly in stabalize. There are reasons why we advise users to use the stabalize mode on the first couple of flights.

Why do users think they know better, ignore the instructions, get strange results and then complain in the forum?

1 Like

You can’t tune the craft in Guided Mode. And you will have to learn to fly in case trouble arises. And eventually it will.


I know but I don`t know exactly change parameter which I must change if i can not fly well.
There are quite a few pid related parameters in the ardupilot full parameter list. Also I tried so much but mostly i failed. my copter my copter was tilting sideways and wouldn’t take off straight.

When users follow our instructions and recommendations, they get a good flying copter.

Here is an example: Almost crashed Quadcopter

The user had issues, but then started following instructions, and in the end got it working!

There are not that many parameters to adjust, if you follow the procedures.

If you do not follow the procedures, and just stare at the 1200 parameters, then you get scared and clueless, yes.

1 Like