Take off issue 3inch cinewhoop


skystar h743 hd dual gyro + km60 blheli_32 esc stack

1507 3800kv motor
3" prop Gemfan D75 3 blade
4s 95c 850mah battery
Weight with battery - 372g

copter firmware 4.3.0 beta1

log file attachment

calculate initial parameters airscrew size in inch 3
3 01-01-1970 05-30-01.bin (649.2 KB)

calculate initial parameters airscrew size in inch default
4 01-01-1970 05-30-01.bin (436.0 KB)

You have your PIDs completely untuned. The default PIDs, which you use, are quite OK for a 9"-sized quad, but typically way too much for a small high-voltage quad.

Could you please provide:

  • the kV rates of your motors;
  • the overall weight of the craft (with a battery);
  • the pitch of your propellers?

I will try to scale the tuning of my 3" quad to your setup, so that you (hopefully) have a reasonable starting point. (After that, some adjustments, including running an autotune, will still be necessary, but the initial flight experience might be better).

@MaxBuzz post updated

My suggestions are as follows:

ATC_ACCEL_P_MAX: 279000
ATC_ACCEL_R_MAX: 349000
ATC_ACCEL_Y_MAX: 103000

ATC_RAT_PIT_P: 0.124
ATC_RAT_PIT_I: 0.124
ATC_RAT_PIT_D: 0.001

ATC_RAT_RLL_P: 0.068
ATC_RAT_RLL_I: 0.068
ATC_RAT_RLL_D: 0.001

ATC_RAT_YAW_P: 0.18 <— these seem to match the default ones, coincidentally
ATC_RAT_YAW_I: 0.018

Note that:

  • The PID values are basically my PIDs scaled by 0.4, and this 0.4 comes from my idea of how that would scale depending on kV of motors, prop pitch, craft weight and voltage. Since our frames are very similar, this might do the trick.
  • The ACCEL values are, again, my values scaled by the weight.
  • These values implicitly assume that you already set up notch filtering, in particular the one using bidirectional DShot. If not:
    • You may want to decrease all PIDs sharply, e.g. by a factor of 2, if you still experience high oscillations at startup.
    • I would strongly recommend to set up filtering anyway. This will allow for much sharper tunes and better flying overall.
2 Likes

tested :roll_eyes:
test.bin (691.6 KB)

Fligh test video

https://drive.google.com/file/d/14avz_lNQhecqIlW4AugWaIAeyVGjIAwd/view?usp=drivesdk

It’s never going to fly with those default Rate and Gyro filter values with a 3" craft. Go to Mission Planners Mandatory Hardware>Initial Parameter Setup.

calculate initial parameters airscrew size in inch 3
Set After change same result
3 01-01-1970 05-30-01.bin (649.2 KB)

You can see 1st post

The log file didn’t attach

Could you maybe please read my entire post, and not just the parameters?


Since you don’t have harmonic notch set up, these particular PIDs may be too high for you. The video rather supports this. Please divide all the _P and _I values by two and repeat the test. If it gets noticeably better, but not flyable yet, repeat that.

And yet again: the default PID values, which Mission Planner seems to set up for you, are too high for your craft!


The filters, which @dkemxr was speaking about, are the following values:

ATC_RAT_PIT_FLTD
ATC_RAT_PIT_FLTT
ATC_RAT_RLL_FLTD
ATC_RAT_RLL_FLTT
ATC_RAT_YAW_FLTT

which can all be safely set to 50 (and even to 100), and

INS_GYRO_FILTER

which can be set to 100 (and even to 200 together with the parameters above).

Please use these values for initial tests (50 and 100 correspondingly).


And a final remark - don’t think that Mission Planner knows what to do! It typically does not. Use your brains instead. If you cannot, for any reason, choose Betaflight.

2 Likes

Where is the compass?

My 1st custom made 450frame pixhawk quadcopter excellent flight
I dont like betaflight

No gps and compass :expressionless:

That’s funny. It’s spinning on the ground and you wonder why. There were many other things wrong but you need a compass.

Take several steps back and start over. A small propped multirotor with Arducopter is nothing like a 450 size craft.

New compass ordered after 2 days delivered

My frame and hardware build good
Trying to understand software parameter setting :relieved:

(post deleted by author)

today test Much better than the first
and 1 more changes MOT_SPIN_MAX 0.95 to 0.65 not shaking
https://drive.google.com/file/d/1Og9T5PYqaCDi6Khv3iYupgNjR1U0Pc6d/view?usp=sharing

Glad to see you have some attitude control at least.

I don’t see how MOT_SPIN_MAX would affect your flying, since in the provided logs your motor outputs never exceed 0.5. That would be really interesting if that does affect your flying. I would rather expect changes from e.g. MOT_THST_EXPO, which is usually much better to be around 0.65 than what default settings suggest.

Just as a side note, Ardu resets the battery consumption counter on powering on. So if you did some tests and then power-cycle without replacing the battery, you either want to adjust the battery capacity, or track the voltage more closely, so that you don’t drain your battery completely, as it was in your last test.

With the current state, you might want to go and run the autotune. It is best done in a nearly still weather (I know not everyone can afford that), and in your conditions, I would find some nice area with soft surface so that a crash would harm less. I would recommend doing your tune one axis at a time, given that an initial tune goes much longer than a tune starting from an already good point, and that your battery is not “infinite”.

cant outdoor flying bacause rain outside flying in parking small area