Switching between "No GPS" to "No Fix" constantly

I am using a custom GPS that I bought from Aliexpress called ATGM336H.
Initially, it can only output standard NMEA data in a 1Hz and 9600 baud rate.
At first, after configuring with u-center, it outputs data NMEA and UBX protocol (View-Message View-UBX-CFG-RAT) in a 115200 baud rate and 10Hz rate of ouput (Message View-UBX-CFG-PRT) to my pixhawk. But I keep get the message on the QGC console saying that “detecting u-blox GPS in 115200” about every 10 second period. And the sat count keep switch from 0 to 16. After connecting to u-center, I found in the bottom right corner, there is a small box keep switch between “NMEA” and “UBX”. Then I remember the output setting that I did is NMEA and UBX protocol. I remember weeks ago also seeing in Mission Planner that in the HUD display my GPS keep switching bewteen "No GPS " to “No Fix”.
My initial thought is that Ardupilot isn’t not capable of using two protocal at the same time and keep thinking that I unplug and plug the GPS. So, the initial solution is to configure the output of the GPS module to output only NMEA messages. But I tried, there is no message in the console, and I don’t have GPS connection, neither.
After configuring the GPS module to output only UBX message. I got “No GPS” message.

So, here I am, posting this problem on the almighty Ardupilot forum. Is there anyone who have similar experience in using your own GPS module?

I advise you to set it to UBX only, 115200 baud at 5Hz. after that connect it to ardupilot and select UBX in ardupilot parameters a well (GPS_TYPE) and let it autoconfigure. The autopilot should take it from there and proper configure your GPS, assuming it has a proper UXB command set.

Hey, thanks for your reply, I will try it once I got time, and I will keep update the issues in this post.
Although, do I still need to change the SERIAL_3_BAUD to 115200, if the GPS_AUTO_CONFIG=1?

Yes. You should do it just in case

Hi, I am facing the same issue with my Hemisphere GPS. How can I do that? Is it supported as it’s also based on NMEA 0183? Help required @QCSUI @amilcarlucas @rmackay9

Ask Hemisphere for support. you probably need to use their tools to set it up.

I have set the GPS. Only the $GPGGA string is coming at a 5 Hz rate. Still, the same issue is persisting.
Does ardupilot doesn’t support hemisphere GPS?

I have a LOCOSYS RTK-1010 that outputs NEMA 0183 ver. 4.1.
The GGA, GLL, and RMC are outputted at 1Hz and GSA, and GSV at 0.2Hz.
Do I need to change the frequency of these messages to prevent the switching between “No GPS” and “No Fix”?

Or where can the issue be?

We use Emlid Reach M2 sometimes as primary gps for our roverboat and it is also set so that it outputs NMEA 0183 messages. we configure the pixhawk to take in NMEA only. we did never change the baudrate and we never had the issue of it switching from no fix to no gps and so on in a loop.
in case it has no fix, it says “no gps” instead… because there is no NMEA messages coming (or just zeros)
it must be noted here that we had to change the settings from EKF3 to EKF2 for modes that use the gps (auto and guided etc) to function (i dont know exactly why that is)