Swiftnav Piksi status glitches

I have been testing out the new driver for the SwiftNav Piksi RTK GPS this week and so far it has actually worked pretty well.

I am, however, seeing one problem. The reported status of the piksi will periodically ‘glitch’ and become 1 instead of 4/5 for between 0.1 - 2 seconds causing the copter to momentarily twitch lightly then come back when the GPS status returns to 5. I first tried it using separate 3dr radios for the Piksi and the Telemetry and had a lot of problems with it. (first picture) I then tried it with the inject GPS function of Mission planner. That seems to have helped. (second picture)

Is there any way I could stop this from happening? It seems that if the Piksi really is losing RTK-fixed lock it should take longer than 0.1 seconds to regain it and it would go to float (status=4) before becoming fixed again, which leads me to believe that it’s not actually losing an RTK fix. Is that correct?

Note: the data in the photos is all from when the copter is in the air. But as I watch the Status tab on Mission Planner even right after it gets RTK lock while sitting a couple meters away from me on the ground disarmed, it does this.

I will also post this on the swift-nav discussion board as well. But I am just curious if anyone else has seen/fixed this problem.

How did you manage to get the Pixhawk and the Piksi to communicate?
I have followed all instruction on the WiKi but in MP I can only see GPS Status 1. No “Nr of Sat” and no information making me believe they are not communicatingat all.

I have originally made a cable myself but later I bought the recommended cable. Still no success!

It is essential, for my project, to have the Pixhawk reading all GPS data from Piksi and communicate it through Mavlink.


I have measured and rechecked the connection between the Piksi and Pixhawk but the do not communicate as they should!
Made me think the RX port on the Pixhawk has been damaged. Replaced connectors between uBlox and Piksi and getting GPS2-info in MP confirming that hardware is OK!

Changed mode to NMEA in Piksi Console. That gave me GPS-status other than 1 but instable. After beeing 3 it reverts to 0.

It must still be a bug in the software for communication with the Piksi

The page “Integrating Piksi with the Pixhawk platform” ought to contain ALL parameters required for the communication.


I’m having the same issue with the piksi connected to my plane. GPS2 Status jumping between 1 & 5.
Let me know if you managed to get to the bottom of it.

mp just reports what the autopilot tells it, this will be a gps driver issue, or the piksi itself loosing lock