Swash pitches full forward with no stick input (pixhawk)

I am trying to figure out what is causing this issue, is this possibly related to auto tune???
Does the pixhawk go into auto tune on first initialization ( green flashing led then a rapid multi colored led and back to green led now solid) …
Can Auto tune be disabled (if that’s what’s happening)??
This is happening on the bench when I’m testing for vibrations (3 times now), I can bring the swash back to level with stick inputs.
Also including a “normal log” along with the swash pitch log…
Any idea’s (Rob) ??
Thank you
[attachment=0]Normal no pitching.BIN[/attachment]
[attachment=1]swash pitched.BIN[/attachment]

I should add that the two other times this happened (both on the bench) , the motor was not running…
It just pitched forward and then went back to level, all on its own… :open_mouth: in stabilize mode
Also including new vibration tests just now completed with good reduction…
[attachment=0]2cm zeal no urthane mts.BIN[/attachment]

Ok so it is not auto tune as I do not have that set up in MP, as for the multi colored leds well that is auto trim…
But why the sudden nose dive on the pitch axis???

OK once again :blush: :blush: :blush: :blush:
I followed the wiki for analyzing logs and believe I have found the source of the issue, it (the full pitch frwd.) happens at the same time as a GPS glitch occurs.
So yes this is happening inside the house and I have not had it happen outside in actual tuning flights!
It appears to be related to that and nothing else according to the error codes I found on the log file for that flight… another AH HA moment!!
The question now is why does the swash pitch full frwd. when a “gps glitch” occurs and this is in stab. mode when it happens.
Can anyone point me in the general direction or setting to resolve the full pitch frwd. when the “glitch” occurs (I don’t want it to do anything if and when the “glitch” occurs)…

Well the “issue” has not come up again and hopefully it will not, the only change I made was to enable the EKF filter with its default settings.
So I will mark this as solved and hope that was all that was needed…