Surface tracking not tracking


I have a quad equiped with a TF03, I have a good height reading, when flying over obstacle, but the surface tracking won’t work.

Here is my config :

I can’t find EK3_ALT_SOURCE
TERRAIN_ENABLE tried 0 and 1

I also setup a channel on my herelink to SURFACETRACKINGUPDOWN with a toggle from 1000 to 1500

During the flight on Loiter, if I press the switch, it will toggle between SurfaceTracking LOW and SurfaceTracking MIDDLE on the messages, but will stay at the same height when flying over obstacle

Hello @bendead

I don’t have a clue of what could be the problem, but just some considerations:

It is not needed to change it for surface tracking, just keep it as default;

This one will only be used to use rangefinder for terrain coordinates while in auto mode;

It is used to enable the use of terrain databases. If it is not the case, just keep it zeroed.

I would double check the RNGFNDx parameters.

Send a param file and some logs so anybody can help you more with this.

1 Like

Hi @ BrunoBagarini

Thanks for your reply.

I will do another flight tomorrow and share the log. I will also try to set an auxiliary functions for the rangefinder, in case I need to enable it, maybe the surface tracking up/down is only there to select an orientation or disable the function, but not activate it.

On the Wiki it says the following :

Okay, I did another test today and it’s very weird. :thinking:

While surface tracking won’t work on the roof of a building that get registered by the rangefinder, it works without problem when flying over a tree nearby.

Maybe the roof is too low or high?

Below is the param file, I will share the log once I am home.

008 RNGF Test.param (18.1 KB)

Sorry man, I am out of ideas of what could be the problem about the roof. Maybe the log can bring some light at some detail.