Sudden increase in motor power without command

I received my new flight controller(Matek F405-CTR) yesterday, flashed the firmware and calibrated sensors. Finally, everything was done so I decided to try to fly it. Firstly I gave too little throttle to see if anything go wrong. It doesn’t seem to me it reacts correctly, so I hold my quadcopter with my hand to feel the thrust vector. I gave a little power with holding it, responded very badly to movements so I was about to stop it, then suddenly throttle increased without my command, not a small %5 increment, it went for %80 power from %20 I guess. I cut the throttle but it stopped after a while and probably it detected as crash, not due to throttle cut. So I would like to see: Why throttle increased suddenly? Why it acts very bad? But the priority of course sudden increment in the throttle. Log is available as an attachment. Thanks. 12 1.01.1980 02-00-00.bin (792 KB)

You had a GCS failsafe and it went into land mode.

Holding a quad with props on is never a good idea.

1 Like

Thanks for the fast reply. Failsafe should be responded with RTL but GPS wasn’t available so it just tried to land, correct? I am using APM 2.6 since 4 years, due to older firmware(s) I can be not experience this or just didn’t enable gcs failsafe, anyway it makes sense. However as I see motor output pwms hitted around of 1700. 2000 should be maximum value. It is pretty high for landing, isn’t it?
Obviously it’s not a good idea, but there’s not any better options I guess. Once it almost about to cut it’s own battery and that’s pretty much worse I suppose.

You have
so may be it tries to climb to 20m before RTL or landing.

Do not hold it, the control loop is going to counter act you movements. Just let it fly, it will behave better.

That’s a good point but it’s a unexpected behaviour. I don’t remember anything like that. I don’t know if these are available for reading in somewhere but I should take a look.

I had pretty bad experiences when flying indoor (shouldn’t do, I know but I don’t have a free space in outdoor, only the flight site -which is my house too but pretty far- has enough space)so I have to fly test it in indoor. disabled failsafe and corrected motor order. Now it’s flying correctly, thanks…