Stream from multiple skyvipers to vlc

Hi, i read that is posible to stream to vlc.

Do you guys know which address command to put in vlc to received video stream from multiple skyvipers ?

You’ll need to invoke multiple copies of VLC, then File->Open Network Stream

Assuming you’re on windows you can also invoke it directly with “vlc.exe rtsp://ip:554/media/stream2”

If you want multiple streams in the same display, the easiest route is probably RSTP->DirectShow->OBS Studio

Keep in mind there are only 3 non-overlapping wifi channels available - 1, 6, and 11. According to FCC docs the controller can operate on channel -1 at 2409mhz, but that still overlaps channel 1:

The drone only transmits 185mW, so the noise floor rises extremely fast due to the inverse square law being a bitch.

Hello, thank for your elaborated reply.

Using multiple instances of vlc is fine for me.

Will it be posible to change streaming port or something like that so to be able to get more than the 3 streams like you mention.

What does the stream2 in your vlc command stand for?

Nothing special AFAIK. stream1 doesn’t exist, I think it’s to distinguish between the SDCard stream(30fps) and RTSP(20fps by default). Perhaps the developers had both available at one point for debugging purposes.

alright thank you.

I got connected to the skyviper wifi then open vlc File->Open Network Stream

and add rtsp://ip:554/media/stream2 also tried rtsp://ip:554/media/stream2.asp and . asx and rtsp://ip:

but i could not get the video stream in vlc, did i do something wrong ?

i tested that the stream works via the skyviper menu camera tab.


Did you replace the “ip” portion with the IP of the drone, or just leave “IP” in place?

Under your current configuration you’ll need to point it at rtsp:// but if you add another skyviper in client mode on another IP address, you’ll need to modify the string to connect to that as well.

great i got it . its working now , thank you ¡¡

You don’t need to specify the 554 port btw.
rtsp:// will work too.

Btw 2, stream can be sent to Mission Planner to display on HUD. Using Control F, picking vlc in right column, entering same address.

Hi OliverB, thank you for that info.

I tried rtsp:// on vlc for Android and the screen goes blank for a second then just exits back to the video selection screen. Am I doing something wrong?