Strange twitchy beaviour flying waypoints on V3.2-rc2

Today I tried flying a few waypoints and noticed a very unstable flying behaviour.

When flying to the next waypoint the Quad wiggles very much. Nose down, nose up and about twice a second. You hear the motors spinning faster and slower all the time.
I has been a while ago since a flew waypoints but it was not like now. It used to be stable and smooth. I don’t know which version or setting introduced this.

I attached the tlog. Starting at 5% I start flying to the first waypoint. Halfway the second I stopped.

Normal flying is fine and also loiter and PosHold are very stable.

Who has an idea? I already compared the WP* values with older settings and these have not changed. I also tried different WP-Speed settings (CH6 knob) but did did not change much in the wiggling.

I had the same problem a couple of months ago and was told it was a known beta problem. I went back to 3.1.5 and am waiting for the next firmware update.

Don’t waist your time trying to adjust the PIDs - it won’t do any good. That’s why it’s a beta version.


Thanks Mike. You saved me probably a lot of time and frustration.

I’ll wait for the next release too.