Strange motor idle issue

So I’m having a strange motor issue - When I arm the motors, pretty much every time one of the four motors (Or 2, 3, 4) of them will be spinning at a slower rate than the rest. When I apply throttle, this slow motor won’t respond to the throttle, but the rest will. I’m able to fix this by just hand spinning the slow motor to be a little quicker, but I’m at a loss as to how to get the motor to initiate and idle right in the first place. If I were using older traditional ESC’s I’d just turn up the idle % and see what happens, but I’m using Dshot ESC’s, and don’t believe that to be possible.

I think it’s also worth noting that I’m using foldable props (And so it would make some level of sense that at idle I may not be getting enough centrifugal accel to deploy them and therefore increasing drag, but I’m still not sure why it wouldn’t respond to increased throttle…)

Does anyone have any thoughts on this one? How can I get the motors to idle properly so I don’t have to go in and hand spin them up quicker?



You can adjust your idle percentage on the ESC options under mandatory in MP. I’d also check all your settings in BLheli32 suite and make sure all the ESC have the same settings. What motors are you using?

Great I’ll give that a shot, thanks! …I missed the mark on the BLheli 32 ESC’s and just have BL Heli S ESC’s, but may end up switching if it ends up necessary. Motors are currently RaceStar 4114s, but will be switching to Tarot 4008’s as soon as they arrive.

The one thing that makes me think it’s not an individual ESC having different settings is that which motors idle too slow and don’t respond to throttle switches around, and sometimes is even all 4 motors at once. Whatever the issue, when the motor doesn’t idle at the expected speed, that motor subsequently does not respond to throttle.

I can’t remember if BLheliS has it, but turn off Low RPM power protection if it does have it. What KV are the motors?

1 Like

The motors are 400 KV - Cranked up the ESCs and still having the same issue… Is it possible to do bl heli s pass through on the pixhawk? I was under the impression that only blheli32 could do that from searching around the forums.

Passthrough only works with BLHeli32 and while the Low RPM Power Protect setting is often a problem with low kV motors this only applies to BLHeli32 also. Set it to standard PWM, you are not going to realize any benefit from Dshot anyway with that craft. If the ESC’s were BLHeli32 you could potentially take advantage of ESC telemetry.

1 Like

What flight controller are you using? What version of AP?

Using a Pixhawk 2.4.8 with 4.0.3 currently - I’ll attempt to use PWM as suggested and report back. (I did try to use PWM from the start but could not get the ESC’s to respond at all, which is how I ended up with Dshot).

As an update, PWM output didn’t fix the issue, but cranking up the idle % on the ESCs helped a bit - will continue to adjust that with hopes that the issue resolves.